Lenovo HD screen installation issue

Gents and Gentle Ladies I am having an issue with my opensuse 11.0 installation. My system is a Lenovo Y550 with an HD screen. I had another system identical to this one that did not have the HD screen and this was the only difference. The first laptop I had had no issues with installation and worked like a beautiful machine with a beautiful OS.
Now, with the new machine after the installation completes successfully and I reach the user log-in screen I log in with the username and password and it begins to boot. Once it has completed booting and moves into loading X11 the screen is blank. It isn’t black mind you it is that grey color that tells you the screen is on but, nothing is displaying and when I hit the reset button the screen displays the processes that are shutting down before it can power off safely. This tells me that the system is loaded but, is just not showing me anything on the display. which means that the display is working and the OS is loaded but, I think there is maybe an X11 driver missing or some such nonsense.
Just wondering if anyone has run into this issue or something. If I need to move my post let me know and I will do so. Get back to me quickly please because the laptop is my girls and she looks like she wants to kill me. (save your fellow linux lover!)

Try to boot in runlevel 3 (init 3) login as user then su to be root and try the command init 5 and look for error messages and repost. Might one of the gurus here knows your problem.

With the girlfriend if x will not start, it’s about time to wear an armor and a helmet. Just kidding can’t resist the temptation.:wink:

Ok after having taken my finals I have time to finally return to this problem and I am having very little luck. Once I attempt to boot and the computer is booting fine. It loads everything but, the screen is blank as I said in the original post. However, if I use the ctrl+alt+F1 or (F2) etc… it allows me to see a command prompt. So, from here how can I diagnose what the problem could be? Again any help would be greatly appreciated.

This reads like a graphical problem. To understand, we need to know what graphics device both of these computers have (ie the one that worked and the one does not work).

My guess is the one that does not work has an Intel GMA X4500MHD, and the one that DOES work has a different graphic device.

According to linlap, this laptop has 3 possible graphic adapters

NVIDIA GeForce G240M 
NVIDIA GeForce G210M 
Intel GMA 4500M

I vaguely recall the Intel X4500MHD does not work with openSUSE-11.0 nor for openSUSE-11.1 but it will work with the kernel in openSUSE-11.2.

Hence if your Lenovo Y550 has the Intel X4500MHD then you need to install the latest openSUSE release.