Lenovo B 50-30 - no shutdown, freezes on text console

Hi everybody!

Since I updated my Lenovo B 50-30 to Leap 42.1 from opensuse 13.2 I have been having several major issues, including random plasma crashes, weird behaviour of fn keys and so on, but the main one is that the machine does no longer shutdown, while it did without any problems on 13.2.

The shutdown process starts, the plasma interface disappears, and either 1) the computer goes to a text console where the cursor blanks for a while and then freezes, or 2) the computer goes briefly to a text console, the shutdown graphic screen starts up and then the computer freezes. In either case there is no other way to wake up the computer than tolon press the power button.

I’ve tried shutting down from kdm, but there is no difference, and texts commands like “shutdown now” lead to the same result. I’ve tried adding several different kernel parameters to the grub config file, as discussed in this thread:


but the only difference I could (maybe) notice is that instead of freezing immediately on a text console, the machine freezes a little later on the shutdown splash animation.

Last resort, I turned off uefi from the bios and tried legacy support, with no result.

So here I am, having run out of ideas :’(. So far Leap has been a major disappointment, a prefectly working machine with 13.2 turned to one which is barely usable.

Any help greatly appreciated, as usual!

Hi, I am just here to give some suggestions.

I had tried to upgrade from 13.2 to Tumbleweed once and failed. The symptoms were sort of like yours. After a little struggle, I made a fresh install of Tumbleweed. Based on my experience, the problem related to Plasma is most likely related to the driver of the discrete card. So maybe you could follow the instructions from the resources on this page, https://en.opensuse.org/SDB:NVIDIA, to disable Nvidia video card completely so that to isolate a factor.

But if I were you, I might try to do a fresh installation on a free partition to find out if the problems are related to old configurations.

Good luck.

Thanks for your reply, but I don’t have an nvidia card, this lenovo comes with an intel ghraphics card. I definitely have to look into video drivers as well, though, as I also have problems with low screen refreshing, especially with some applications.