Lenovo A475: Tumbleweed won't boot, but Ubuntu does

Hi all, I got a new Lenovo A475 laptop (running the latest UEFI firmware, v1.0.9). I’m having an odd issue and I’m not sure how to troubleshoot it. I’m hoping that you can help guide me in the right direction.

First of all, the UEFI firmware has lots of boot modes:
-UEFI with Secure Boot
-UEFI with CSM
-UEFI without CSM
-UEFI/Legacy (UEFI first)
-UEFI/Legacy (Legacy first)
-Legacy

With a Ubuntu 17.04 usb stick, and the UEFI firmware in either “UEFI with Secure Boot” or “Legacy” modes, I’m able to install and boot Ubuntu normally.

With an openSUSE TW (12/15/17) usb stick, the stick is not bootable in “UEFI with Secure Boot” mode (or any of the UEFI boot modes). Legacy does allow me to start the installer. However, after the installation is complete, openSUSE will not boot (no errors, the Lenovo UEFI firmware just dumps me to the “pick a boot device” screen). The exact same usb stick is bootable in both UEFI and legacy modes on several other computers I’ve tried.

I managed to boot the openSUSE TW installer in UEFI mode by putting rEFInd on a usb stick and putting the openSUSE installer on another partition on the stick. That allowed me to complete the installation in “UEFI with Secure Boot” mode, but after the installation is complete, openSUSE will not boot (no errors, just like the legacy boot).

So, as far as I can tell, there’s something about the combination of this laptop plus openSUSE that’s causing an issue, but I’m not sure where to go from here. Any ideas?

Well, I’m not sure exactly what I did to fix it, but it’s working now. I’ll detail what I know and maybe it’ll help someone else if they run into the same issue.

So the install did finally produce a bootable machine after I re-imaged the usb stick. I always verify the SHA256 hash of my downloads of the ISO, but I don’t usually make sure that the copy to the usb stick was successful. So, maybe I had a bad bit on the usb stick? I did still have to create a bootable usb stick by:

-putting rEFInd on the stick
-using gdisk to expand the disk and create a new partition
-using dd to copy the ISO to the new partition

I also had been playing with the secure boot key options. This Lenovo has three options:
-Reset to Setup Mode
-Restore to Factory Keys
-Clear All Keys (or something to that effect)

I’m 90% sure that I had tried previous installs while in “Setup Mode” and regardless, whatever mode I was in, Ubuntu was able to do a bootable install, while openSUSE was not.

But for the final, successful install, I had done a Clear All Keys, followed by a Restore to Factory Keys, followed by a Reset to Setup Mode before doing the install.

Not sure this is relevant here, but some laptops come with an Ubuntu EFI key pre-installed (notably ASUS, maybe Lenovo too?)
This might explain why Ubuntu was able to install without tweaking the EFI/Secure Boot configuration first.

Iso should only be copied too the device NOT a partition on the device. The image is complete and does not need any partitions predefined

Normally, that is what I do, but on this laptop, no matter what the UEFI boot settings are, it refuses to boot the USB stick in EFI mode (legacy works though). Only if I use the rEFInd boot manager and then dd the openSUSE ISO to a partition on that stick (so that rEFInd can find it), can I boot the openSUSE installer in EFI mode.

Hi
Sounds like you have been hit with the intel_spi bug…? What other systems have you tried to boot aside from Ub* and Tumbleweed?

BIOS all up to date?

Bug #1734147 “corrupted BIOS due to Intel SPI bug in kernel” : Bugs : linux package : Ubuntu?