Lenovo A475 display stops updating after application is opened

Hi all, I hope someone can help me figure this out.

The symptom is that after opening a GTK application (Konsole and Firefox are the two I use most regularly), the screen stops updating. The mouse pointer still moves and it even changes shape (e.g., into a double-headed arrow at window borders, etc). I can still work with the windows, but I can’t see what I’m doing. If I switch to another virtual terminal and back, then I see the correct screen again, but it still doesn’t update.

If I kill the desktop session with ctrl-alt-backspace, then that lets the screen update again, at least until another GTK application is opened.

I’m running Tumbleweed and this originally happened to me over the summer. At the time, I was using XFCE, but I found that using KDE caused it to work right. But then last week, it suddenly (suddenly == no recent updates applied) started again. And this time, the choice of desktop environment doesn’t seem to matter.

I went as far as reinstalling the entire machine from scratch and it’s still happening.

The cpu is an AMD Pro A12-9800B R7. The gpu is an integrated graphics AMD Wani 1002:9874 using the amdgpu driver.

I don’t have any answers for you. However, I’ll note that “konsole” is not a GTK application, as far as I know. It is a QT application.

So maybe you have narrowed your problem down a bit too much.

You’re right… I thought for some reason that some apps were working and others weren’t, but I just tried out some more and everything is broken. The only thing that does work is the taskbar. I can open/close the KDE menu just fine and I can use network manager to setup a wireless connection just fine. But, if I try and do anything that spawns it’s own window, then the whole screen stops updating (including the taskbar). I’ve updated the title to remove the reference to GTK.

Hi
I have an Wani/Topaz dual graphics A10-9600P works fine, so are you running Wayland or Xorg? How are you updating the system, via zypper dup only?

I get some screen tearing under GNOME but fixed this by adding the amdgpu.dc=0 to the kernel boot options.

My savior!

You gave me not one, but two solutions. Without the amdgpu.dc=0 boot flag, Wayland works great. And with amdgpu.dc=0, Xorg works great. So, it appears to be some conflict between Xorg and display code.

I think I’ll permanently add amdgpu.dc=0 to my boot parameters and consider this solved.

Thanks for your help!