Legion Pro 7 16ARX8H External Speakers Not Working

I’ve been waiting some time for the kernel be patched for this laptop so that the external speakers will work but after a few months am tired of waiting so I figure I’d post here. It seems the kernel was patched a while ago and the speakers should work, but they don’t in OpenSUSE. Should I file a bug report or is there someone else here who might be able to direct me in how to get them working? The link below is one of the references to the problem where someone stated that the issue was resolved in a kernel older than the current one in OpenSUSE.

Have a look at this: https://forums.lenovo.com/t5/Ubuntu/Ubuntu-and-legion-pro-7-16IRX8H-audio-issues/m-p/5210709?page=22
Download the zip file from the second link in the top post, and unzip it in /usr/lib/firmware/. Then reboot.

I’ve tried that before and just tried it again. It doesn’t work. That thread is for the intel version of the AMD laptop I have.

There are bunch of files with the same name but .xz at the end that are dated just a few days ago. The files from the link are quite old in comparison. Should I try to remove the .xz files and see if that works?

Install and run pvucontrol-qt. ClickOutput Devices and share a screenshot here.

This thread suggests the issue was resolved a while ago in Ubuntu which makes me think it’s an OpenSUSE issue and not a kernel/driver problem: https://ubuntuforums.org/showthread.php?t=2490273