Leap42.3 , After install windows have no borders and got stick left top corner

I installed Leap twice in Virtual Box, first 5.1.xx and now 5.2.0 (latest), but most windows in uncontrollable, and got stick on left top corner, and no borders visible. I used all the defaults setting during installation. It also look like one cannot resize the windows/ I tried to create new user , same problem.
I desperately search for ‘System Settings > Workspace Behaviour > Screen Edges’, but could not find them.

I have not yet made any major installs and only did a system update in Yast, and install Tortoise, Krusader, MC, Mlocate , KRename and KDiff3. This was all installed from the opensuse webpage

I been using VB now many years and have many system running in VB, and have at least build 20+ systems in the last few years, so I am not new to the process,
I am also using opensuse from 5.3 (1998) everything just worked then. I never had any Linux system where the windows did not worked, and googling did not help, so I need help where to start.

I am a about to give up on my precious Linux distribution…

Need more info…

  • Are you running 42.3 as your HostOS <and> installing a 42.3 Guest? Or, some other combination?
  • Have you updated your HostOS(espeically) and if you are also running an openSUSE Guest with the following command?
zypper up
  • Where did you install your Virtualbox, from the OSS, the openSUSE virtualization repo, or a download installer from Oracle Virtualbox?

What do you mean by “windows?” - Most often, a “window” describes an application graphic console within the OS, but I suspect maybe you’re more specifically talking about the way Virtualbox works… You launch the virtualbox virtual machine manager, then from that you can “start” a virtual machine, and the virtual machine starts up in its own “window”

If the above is what you are talking about, then have you tried using the virtualbox hot key combo to enlarge a virtual machine to Full Screen (and undo) by the “host-key”-F combo(By default the host key is the right CTL key)?

As for window re-sizing, to some degree that depends on whether you’ve installed the Guest Additions into the virtual machine or not… By default any openSUSE installed as a Guest should automatically install these, but this won’t likely be installed in any other distro or OS(You’ll either have to install the package or from the a mounted ISO).

If the second half of this post doesn’t address whatever you’re asking, you’ll have to provide answers fro for the questions at the top and provide a more detailed or descriptive question.


AFAIK this behavior means your display manager is not working. X gives the framework for graphics windows, but it is the DM that enable things like resizable/movable windows, decorations, etc. For example, KDE used KDM (now it’s simpleDM, I think). Other desktops may use other DMs by default.

This is the limit of my experience, perhaps you could try different windows managers - IINM they are selectable from the login screen, and also can be set with yast or something like that.