LEAP42.1 fstab edited(added ntfs) now unbootable

So, I added my ntfs drives with YaST. It mounted from within SUSE, everything was fine.

I then rebooted to see if it mounts. It took forever to get to the emergency terminal. I tried to remove the 2 ntfs additions from the fstab in etc, it did not work.:sarcastic:

I have removed the 3 standard mounts, re-added their uuids.

I just cannot seem to get it to boot and I simply have no idea why.

Turn off “fast boot” in your windows system. It leaves the NTFS file systems in an unstable state, and that is possibly the cause of your problem.

In my windows system? As in, boot to windows and disable it? I don’t think Win7 has that, uh, is it not a BIOS option? I am totally confused, I have googled, closest I see is to enable memory check and/or quickboot in BIOS

I have also tried removing the ntfs partitions from fstab file and booting without them. Re-installing grub just gave me a strange error “/run/lvm/lvmetad/socket: connect failed: No such file or directory” “WARNING: Failed to connect to lvmetad. Falling back to internal scanning.”.

I used the default partition setup when I initially installed.
sdb drive:
sdb1 ±8Mb BIOS GRUB
sdb2 ±3Gb Swap, sdb3 ±10Gb OS
sdb4 remaining space

Mount points and FS type:
sdb2 : fs=Swap, is set to “swap”
sdb3 : fs=XFS, is set to “/”,
sdb4 : fs=XFS, is set to “/home”

“Optional Kernel Command Line Paramaters” By default “set by YaST?”.

resume=/dev/sdb2 splash= silent quiet showopts

fstab only has the 3 sdb drives listed, without all of them I cannot even get to emergency terminal and have to use the live installers recovery terminal.

Sorry I meant when I config grub(grub2-mkconfig -o /boot/grub2/grub.cfg), not install.

I think that’s Windows 8 or later. So maybe your problem is different.

If you hibernate Windows, you will run into that issue. So if you have hibernated Windows, then be sure to boot into Windows first before you reboot into opensuse.

I have also tried removing the ntfs partitions from fstab file and booting without them. Re-installing grub just gave me a strange error “/run/lvm/lvmetad/socket: connect failed: No such file or directory” “WARNING: Failed to connect to lvmetad. Falling back to internal scanning.”

That should only happen if you are using an LVM. Did you forget to mention that? In any case, I think it is a harmless message. Okay, maybe you also get that when running “grub2-mkconfig”, and it can be ignored.

Maybe we need to know more about your system.

It looks as if “/dev/sdb” is GPT partitioned (otherwise there wouldn’t be a BIOS_GRUB partition). Is Windows on “/dev/sda”? Is this a UEFI system. Is Windows installed to use UEFI or legacy booting?

I don’t use hibernation.

Well I used YaST to mount the ntfs drives, didn’t use a LVM.

I forgot that mkconfig doesn’t work with chroot. Ran “grub2-mkconfig” it was “successful”, but still didn’t change a thing.

Yes Windows is on /dev/sda. SUSE nor Windows are uefi, both are legacy/MBR.

Maybe post the content of “/etc/fstab”. Be sure to use code tags. Perhaps we will be able to spot the problem.

fstab looks pretty much like this.

UUID=5a075170-9c90-453b-93e4-304af2a86e8e swap  swap defaults 0 0
UUID=2eada8fa-afa9-492b-99fb-1dc8c9bcbf99 /     xfs  defaults 1 1
UUID=55c94878-c28a-4757-9a3c-5a78f2a2de9a /home xfs  defaults 1 2

Assuming that those are the correct UUIDs, then I can only suggest remaking the “initrd”. Do you need help with that?

I actually just attempted. Not actually sure how to. Would really appreciate the help.

You will need to do something like this:

First boot your rescue media. Then:


# mount /dev/disk/by-uuid/2eada8fa-afa9-492b-99fb-1dc8c9bcbf99  /mnt
# mount /dev/disk/by-uuid/55c94878-c28a-4757-9a3c-5a78f2a2de9a /mnt/home
# mount --bind /dev /mnt/dev
# mount --bind /sys /mnt/sys
# mount --bind /proc /mnt/proc
# chroot /mnt
####### now we are in a chroot environment
# mkinitrd
# grub2-mkconfig -o /boot/grub2/grub.cfg
# exit  ### leave chroot environment
# umount -R /mnt  ## unmount recursively
# shutdown -r now ## reboot to test if it works.

I suggested the “by-uuid” names for mounting, since that tests whether the fstab entries are right.

All the commands ran without warnings except for grub2-mkdir. Still booting into emergency mode. Not sure if I should actually exit chroot before doing mkdir, but it gave the same warning as last time.

When at loading screen and I press alt+space, near the bottom it says

Listening on LVM2 metadata daemon socket
expecting device dev-disk-by\x2duuid-5a075170\x2d9c90\x2d453b\x2d93e4\x2d304ad2a86e8e.device
 with another line with a different x2duuid

I honestly have no idea what that is. Or if it significant.

Hmm, well I was just checking to see if anything seems odd. Not that I am completely clued up to start with.

I came across the command cfdisk, it listed sdb1’s type as “BIOS boot” but sdb2-4 are listed as “Microsoft basic data”. I can change the type with cfdisk, not sure what it would have to be or if it would make a difference.

That looks strange.

Maybe you need to reinstall grub.

For that, do all of the same stuff as before, to get into a chroot environment. Then use:

# grub2-install /dev/sdb

Hmm, I’m assuming that your BIOS is configured to boot from the second drive. If, instead, you are using Windows Boot Manager to boot linux, then you might also need to set that up again.

As for partition types: they shouldn’t matter. Personally, I would use “gdisk” to change the linux partitions to type 8300 (that’s what “gdisk” uses for linux). As far as I know, “Microsoft-basic-data” means about the same as “unspecified”, and the partition tool that the installer uses sets the partitions that way.

The thing is, that I have reinstalled grub, but not in chroot mode iirc.

Bios is configured for the second drive iirc.

Well I will see if type 8300 has any difference.

Grub installed and configured fine, again an lvm message when configuring.

Setting type did not do anything.

This makes no sense…

On top of the LVM2 whatever that is.


Listening on LVM2 metadata daemon socket.
expecting device dev-disk-by\x2duuid-5a075170\x2d9c90\x2d453b\x2d93e4\x2d304ad2a86e8e.device...
expecting device dev-sdb2.device...
with another line with a different x2duuid

You can check “/etc/default/grub” to see if the strange uuid message is related to something there.

According to fstab this is your swap device which is missing. Please show output of blkid (from live media if needed).

I fell asleep, sorry.

blkid output: (I typed it out from an awful phone photo, the 0’s look exactly like 8’s and some e’s like c’s. Will use correct values from blkid for corectness.)

/dev/sda1: LABEL="2tb" UUID="00FC7F68FC7F4F84" TYPE="ntfs" PARTUUID="8dfa36b3-01"

/dev/sda2: LABEL="2tbx" UUID="EAD4F3DBD4F3A7C9" TYPE="ntfs" PARTUUID="8dfa36b3-01"

/dev/sdb1: PARTLABEL="primary" PARTUUID="4c26d5cd-369b-4d62-b332-5a695eaf8b82"

/dev/sdb2: UUID="5a875178-9c98-453b-93e4-384af2a86e8e" TYPE="swap" PARTLABEL="primary" PARTUUID="bfcd99e2-b65d-4be7-8133-b4c67d7f2a6f"

/dev/sdb3: UUID="2eada8fa-afa9-492b-99fb-1dc8c9bcbf99" TYPE="xfs" PARTLABEL="primary" PARTUUID="3a78a95e-ceb6-4454-9499-6497f416c070"

/dev/sdb4: UUID="55c94878-c28a-4757-9a3c-5a78f2a2de9a" TYPE="xfs" PARTLABEL="primary "PARTUUID="fdb2114b-9bab-432c-b181-05e03176c76c"

/dev/sdc1: LABEL="EFI" UUID="67E3-17ED" TYPE="vfat" PARTLABEL="EFI Sysytem Partition" PARTUUID="dd946878-f32a-44bb-83c7-11ea050443d0"

/dev/sdc2: UUID="05400ce2-0b55-30ba-a423-f48cfa91f2ee" LABEL="Untitled 1" TYPE="hfsplus" PARTUUID="5ff785f7-83ee-47f2-818e-5886579b8777"

/dev/sdc3: UUID="5f9abfe9-76ef-3b55-a82e-87522a7ca4df" LABEL="Recovery HD" TYPE="hfsplus" PARTUUID="375d3a07-5834-44ca-a4f7-1ea14e3aae33"

/dev/sr0: UUID="2015-12-04-04-34-41-00" TYPE="Software Books" TYPE="udf" PTTYPE="mac"

sdc is a mac setup, sr is a disc written with mac.

I really thought this would be an easy fix.