LEAP: Where Is xorg.conf

Hi,

I have a cyboirg RAT 3 mouse which basically doesn’t work under LEAP 42.2. As I understand it I have to edit the xorg.conf file to contain the following:

Section "InputClass"
Identifier "Mouse Remap"
MatchProduct "Madcatz Mad Catz R.A.T.3 Mouse"
MatchDevicePath "/dev/input/event*"
Option "ButtonMapping" "1 2 3 4 5 6 7 8 9 0 0 0 0 0 0 0 0 0"
EndSection

Can anyone tell me *where xorg.conf is (haven’t figured yet how to search via the GUI)? I have looked in /etc/X11/xorg.conf.d but it isn’t there. Do I need to create the file from scratch?

Also, if there is anything else I need to do (like put the above in a particular place in that file), can you let me know?

Thx :slight_smile:

Keke
*

Create a file named 20-ratmouse.conf in the folder /etc/X11/xorg.conf.d and put the content in it. Reboot and it should work.

Hi,

That made it work a bit but it doesn’t seem to work all the time. By that I mean the cursor is available (I can move that all around the screen), sometimes some things highlight underneath it but I can’t click on things. Interestingly I sometimes can grab the top bar of a window that’s open and move it.

Presumably that’s something wrong with the code I found?

Keke

According to the Arch wiki the mouse should be fully functional with this:


Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "evdev"
    Option         "Name" "Saitek Cyborg R.A.T.3 Mouse"
    Option         "Vendor" "06a3"
    Option         "Product" "0ccc"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/event4"
    Option         "Emulate3Buttons" "no"
    Option         "Buttons" "7"
    Option         "ZAxisMapping" "4 5"
    Option         "ButtonMapping" "1 2 3 4 5 6 7 0 0 0 0 0 0 0"
    Option         "Resolution" "3200"
EndSection

Thx but unfortunately it still doesn’t seem to work.

Can you clarify something please? Does every “.conf” file in that folder get processed regardless of name? I ask only because I originally believed that the file I need was xorg.conf so …

Apologies but my background is Windows so much of this is new to me.

Thx

Keke (James)

The manual page for “xorg.conf.d” is pretty clear about what files will be
processed.

> DESCRIPTION
> Xorg uses a configuration file called xorg.conf and files ending in the suffix .conf from the
> directory xorg.conf.d for its initial setup.

-> man xorg.conf.d (or man xorg.conf)

AK

Never attribute to malice that which can be adequately explained by stupidity.
(R.J. Hanlon)

I might be on the wrong track here, but perhaps the underlying Xorg input driver is affecting behaviour. I notice that the config file Knurpht referred to is a config for the evdev driver, but perhaps libinput is in use. Anyway, you can check his with

grep "Using input driver" /var/log/Xorg.0.log

I’m not familiar with your hardware, but it may be that evdev is required to get the correct behaviour invoked. Anyway, we can advise further depending on the output of the above. Some experimentation may be required here.

Also, if you copied his example literally, you may have the incorrect /dev/input/event* device. You can check this with

xinput

From that you can get the device name and use the following to get the appropriate device node

xinput list-props <your device name>

FWIW, a quick read of the Mad Catz Mouse - ArchWiki page mentions the following suggested configurations (different button mappings to what has been posted here so far)…

MadCatz R.A.T.3:

RAT3 mouse

Section “InputClass”
Identifier “Mouse Remap”
MatchProduct “Madcatz Mad Catz R.A.T.3 Mouse”
MatchDevicePath “/dev/input/event*”
Option “ButtonMapping” “1 2 3 4 5 6 7 8 9 0 0 0 13 14 15 16 17 18”
EndSection
This configuration worked for me on my old Saitek Cyborg R.A.T.3:

RAT3 mouse

Section “InputClass”
Identifier “Mouse Remap”
MatchProduct “Saitek Cyborg R.A.T.3 Mouse”
MatchDevicePath “/dev/input/event*”
Option “ButtonMapping” “1 2 3 4 5 0 0 8 9 0 0 0 13 14”
EndSection

Hi Deano,

I did that, all of it because I wasn’t sure whether you meant me to use both or just one (there appeared to be two configurations), and now my system stops at a prompt:

**Welcome to openSUSE Leap 42.2 - Kernel 4.4.27-2-default (tty1)

linux-r jtm:~>**

I can’t get into GUI mode however I am able to go into “su” mode so I am editing the file to see if I can get back to the GUI reboot.

Keke

Remove the file(s) you created and start over.

Hi Deano,

I edited the 20-ratmouse.conf file and, long story short, used the second of the two you posted and that appears to have worked (based on a reboot and a cold start).

Thank you most gracious one for your help (I’ll be back with the next query very soon) :slight_smile:

Keke

Yes, there were two configurations mentioned (for different models). Glad to read the at the second configuration worked for you.