Leap: How to Install onto an Asus Prime Z590-A MB

Hello, All.

I built a new computer:

  • Asus Prime Z590-A M/B
  • on board video
  • Intel i9-10850K
  • 32 GB ram
  • M.2 NVMe SSD 500 GB card (no hard drive)

I have attempted to install Leap via DVD (USB efforts failed outright). It loads up drivers (the initial load sequence). But it then hangs and the screen goes black and the keyboard (but not the mouse) lights go out.

I have the latest bios installed.

Has anyone any thoughts as to what is the block and how to get Leap installed?

Many thanks,

Hi and welcome to the Forum :slight_smile:
USB, I suspect it has 3.0 or 3.1 ports, don’t have a 2.0 (or legacy USB support BIOS setting?), AFAIK USB can be an issue if it’s not in a 2.0 port…

Likely all the hardware is too new, can you download and try a Tumbleweed live or rescue system on USB to see if that boots?

You could try pressing the e key at the Install media GRUB menu and try adding nomodeset at the end of the linuxefi line and pressing F10 to boot and see if that helps.

You could also try the Leap 15.3 Beta as that does have fixes backported for some of the newer CPU’s even though beta only a few weeks away from release… If it doesn’t then you might be better to raise a bug report against the beta release.

Hello, Malcolm. And thank you for the welcome.

Lo and behold, it does appear that the front USB slots are USB 3.2. However, the rear slots have USB 2 so I will give that a try later.

As for adding ‘nomodeset’, that was the solution. I suspect I will have to figure out how to add it permanently to the boot stage but as of now, the installation is working perfectly. It is a bit like magic, so can you explain what this addition does?

Thanks, Malcolm. I truly appreciate your help.



Once you resolve the GPU driver problem you do not need nomodeset. nomodeset reduces graphic performance and resolution:’(

You should only need for the install, adding nomodeset tells the system to only use the video modes in the BIOS and not to load any video drivers. I suspect it’s the newer CPU/GPU and probably needs a bug report and fixes added (for Leap 15.3, I doubt Leap 15.2 will get much attention). You probably won’t get good resolution with this, but it will/should get the system to a desktop GUI and work on a fix.

You may have to add after the install reboot, or may not… if needed it can be added via YaST bootloader under the kernel options and removed once fixed, or move to Leap 15.3 and investigate then.

Thanks, Malcolm. The USB does in fact work when I plug it into a USB 2 slot at the back of the computer. So, I will install 15.3 tomorrow using it to see what happens. You (and gogalthorp) identify a further issue I had not anticipated - poor resolution (relatively speaking). I note that the boot text does include ‘nomodeset’ (a carry-over from my installation edit?) and I will remove it to see what happens once I have the system up and running under 15.3.

Thank you again for taking time to respond to my concerns, and thank you, too gogalthorp for chipping in.


There is an option you can try with 15.2, i915.force_probe;

(From /sbin/modinfo i915 and parm: output)

force_probe:Force probe the driver for specified devices. See CONFIG_DRM_I915_FORCE_PROBE for details. (charp)

See https://cateee.net/lkddb/web-lkddb/DRM_I915_FORCE_PROBE.html

If you provide the following, can come up with the right syntax;

/sbin/lspci -nnk | egrep -A3 "VGA|Display|3D"

Thank you, again, Malcolm for the advice. I was able to install 15.3 via USB and it appears to install similarly to 15.2, but there is no recognition of the network, and the light on the cat5/6 connector is yellow, indicating no connection, so I will have to work on that issue, too. It worked with 15.2 so I will reinstall 15.2 on the weekend to see if it brings back the network. I can then try your other solutions for video.

Thank you, again, for your kind and patient help.


MarkH, the easiest method should be using Tumbleweed which brings also a lot of other very actual software applications (like gnome40). In my opinion the only draw back is - sometimes software and their layouts are changing. This flavor of openSUSE is a good choice for very modern desktop environments and hardware components.
But if more frequent software changes are a nightmare for you, I can understand that you are preferring Leap.

It seems on Leap there are two building places:

With 15.3:
Because it is still beta, the needed Intel I225-V network driver is probably not backported at this time.
“Backported” because this driver is normally in kernel since 5.8. But openSUSE prefer for compatibility reasons with SLE, kernel 5.3 and therefore a lot of drivers has to be backported.
Maybe I am totally wrong here… Don’t hesitate to correct me.

With 15.2:
Intel I225-V driver seems to be already backported but not the newest graphical intel driver.

With the latter, maybe it is an option to use a newer kernel…


After that, but instead of Kernel:HEAD:

zypper ar https://download.opensuse.org/repositories/Kernel:/stable/standard/ repo-newkernel
zypper mr -fp 90 repo-newkernel
zypper ref
zypper dup --allow-vendor-change --from repo-newkernel

Interesting to hear what the others are thinking because I am relatively new on this linux distribution.

Hi, Malcolm, and hello gendjaral. My apologies, but I can’t figure out what you are both advising. I am trying to refamiliarise myself with opensuse. Could you perhaps un-compress your suggestions?

For example, I am not sure what this option means: i915.force_probe. Where does it go and how? I did locate the file “/sbin/modinfo” but that is as far as I was able to go. I cannot recall how to open up such a document and amend it (assuming it is akin to a batch file). However, is it simply to go into the boot sequence, if so, should it go in where ‘nomodeset’ was placed?

And I am not sure what is meant by: “See CONFIG_DRM_I915_FORCE_PROBE for details. (charp)”.

And gendjaral, I believe you are saying to run the zypper scripts manually from command line as administrator?

My apologies for my lack of knowledge. I am very familiar with working within command mode in OS/2 and DOS, and I used to be happy working within Suse. But it has been a while. A bit of help getting back up would be most appreciated, if you have the time and patience.



The link I added gives information about this, if you run that lspci command and post the output to identify what to add. The information is entered into the boot kernel options, this is done via YaST -> Bootloader.

Hi, Malcolm,

I had to install the lspci command. Once available, I was able to identify the device as 8086:9bc5 (and controller 8086:43ed). So on reboot I edited the boot loader by replacing nomodeset with


But it failed.

I removed the 8086 and ran i915.force_probe=9bc5, which failed, and I then tried the controller 8086:43ed, and simply 43ed, both failed.

Any thoughts?

Thank you for the help.


That device is present in the Leap 15.2 kernel…

 uname -a
Linux oscar 5.3.18-lp152.72-default #1 SMP Wed Apr 14 10:13:15 UTC 2021 (013936d) x86_64 x86_64 x86_64 GNU/Linux

/sbin/modinfo i915 | grep 9BC5
alias:          pci:v00008086d00009BC5sv*sd*bc03sc*i*

So don’t need to force, need to look elsewhere…

What is the output from;

inxi -Fxx

How did you manage to install and not have the lspci command??? Wonder what else is missing???

What is the output from;

inxi -Fxx

Thanks, Malcolm. Here is the script returned:

Graphics: Device-1: Intel CometLake-S GT2 [UHD Graphics 630] vendor: ASUSTeK
driver: N/A bus ID: 00:02.0 chip ID: 8086:9bc5
Display: x11 server: X.Org 1.20.3 compositor: kwin_x11 driver: intel
unloaded: fbdev,modesetting,vesa resolution: 1024x768~76Hz s-dpi: 96
OpenGL: renderer: llvmpipe (LLVM 9.0.1 256 bits) v: 3.3 Mesa 19.3.4
compat-v: 3.1 direct render: Yes

Should be the i915 not intel…

Graphics:  Device-1: Intel Xeon E3-1200 v2/3rd Gen Core processor Graphics driver: i915 v: kernel 
           bus-ID: 00:02.0 chip-ID: 8086:0152 

           Device-2: NVIDIA GK208B [GeForce GT 710] vendor: ZOTAC driver: nvidia v: 465.24.02 
           bus-ID: 01:00.0 chip-ID: 10de:128b 
           Device-3: NVIDIA GK208B [GeForce GT 710] vendor: ZOTAC driver: nvidia v: 465.24.02 
           bus-ID: 03:00.0 chip-ID: 10de:128b 

           Display: x11 server: X.Org 1.20.3 compositor: gnome-shell driver: 
           loaded: modesetting,nvidia unloaded: fbdev,vesa alternate: intel,nouveau,nv 
           resolution: 1920x1080~60Hz s-dpi: 96 

           OpenGL: renderer: Mesa DRI Intel Ivybridge Desktop v: 4.2 Mesa 19.3.4 compat-v: 3.0 
           direct render: Yes 

Is xf86-video-intel installed? If so delete and reboot…

	gogalthorp, I don't know. I did the 'cnf ispci' step, I believe it then asked that I did a zypper step, and it then downloaded.

I believe I removed it in Yast. Now inxi -Fxx reports:

Graphics: Device-1: Intel CometLake-S GT2 [UHD Graphics 630] vendor: ASUSTeK
driver: N/A bus ID: 00:02.0 chip ID: 8086:9bc5
Display: x11 server: X.Org 1.20.3 compositor: kwin_x11 driver: N/A
note: display driver n/a unloaded: fbdev,modesetting,vesa alternate: intel
resolution: 1024x768~76Hz s-dpi: 96
OpenGL: renderer: llvmpipe (LLVM 9.0.1 256 bits) v: 3.3 Mesa 19.3.4
compat-v: 3.1 direct render: Yes

Where does this take me?
Thanks, Malcolm. Mark

lspci is part of the base system should have been there from the start. Note that is lower case LSPCI not ISPCI. ls is short hand for list in this case list PCI devices

Ah, a typo on my part. Thanks, gogalthorp. LS now understood. :slight_smile: