LEAP freezes during start up. Help

My computer has been working great for months, but this morning has frozen.

I have an HP elitebook with LEAP 15.0. Last night I went to bed and it was working normally. This morning when I went to wake up the screen, it stayed black.

After trying multiple unsuccessful methods to wake up the screen, I powered off the computer with the power button.

Now when I go to restart it, it freezes on the screen with hopping diamond. I’ve tried the advanced options and none of those are successful.

Any ideas on what happened and how to fix this?

I have some more info. When I use the advanced options and boot from an older version, it freezing while scrolling. So I can see the text. I’ve got a screen shot using my cell, but not sure how to upload using my cellphone.

Anyways, there is a time out error, then it says dependency fails for boot/efi, and then every other option it tries, the dependency fails too.

I’ll work on getting that image on this thread. Maybe that will help.


Click this link to see the screenshot with error messages:


Looks like a missing or failing disk to me

the hard disk may be dead

Any suggestions for moving forward?

This is odd. I didn’t install any updates yesterday. I was only using the computer for web browsing and document creation. Normally usage.

I’m at loss for why there is a disk problem and how to troubleshoot.

Problem solved by using a USB to boot the OS and selecting update. I’m baffled why this happened, but happy it is fixed.

I did check the hard drive and it is working fine.

Case closed. Thanks