Leap fails to boot after kernel security updates

I’ve just moved to openSUSE Leap after many years on LinuxMint, so I’m new here!

After installing two security updates the system would fail to boot. After the initial boot screen everything went blank. I was able to boot from an older kernel (and then remove the newer kernel via YaST2) but it’s not ideal to have to ignore security updates!

The updates were openSUSE-2018-762 and openSUSE-2018-826.

Kernel BEFORE updates was 4.12.14-lp150.12.4.1
Kernel AFTER updates was 4.12.14-lp150.12.10.1

I tried just installing update 762, but that had the same problem and I had to revert to the older kernel. I haven’t tried just installing update 826 but I guessed that they should be done in order?

Any help from anyone, or can I register a bug or something?

I’m on a very fresh install of Leap 15.0 64-bit, with / partition on an SSD (with Btrfs) and /home partition on a hard-disc (with xfs). I can happily add more info if you tell me what to do :slight_smile:

Do you read the Posts about that Problem here in the Forum?

All my laptops with NVidia chips failed with 4.12.14-lp150.12.10 that worked fine with earlier kernels- it appears that they added nouveau support into the kernel this is not compatible with my chipset and probably yours too. No laptop with only Intel graphics had a problem.

I added the nouveau.modest=0 on my linux line in front of the splash= and that fixed the problem - your line might be different than mine as /dev/sda2 is my swap file and I want to see what loads so I changed the silent to verbose.

I fixed this in /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT=“resume=/dev/sda2 nouveau.modest=0 splash=verbose showopts”

and ran this as root to fix the problem

grub2-mkconfig -o /boot/grub2/grub.cfg

Kernel 4.12.14-lp150.12.10.1 appears to be broken, see https://bugzilla.opensuse.org/show_bug.cgi?id=1104121
Boot a previous kernel until next update.

Thank you for some quick replies!
I did browse through about 10 pages of the Install/Boot/Login posts to see if anything was similar to my problem, and didn’t find anything.

Yes, I have an NVIDIA Gt240 graphics card. I’ve been running Nouveau, though I tried out the drivers from the Nvidia repository and spent a worrying few hours trying to get my system working again!

Larryr, I’ll keep that suggestion in mind. Thank you. For the time being I’ll avoid installing the updates and wait for new kernel updates to arrive to see if that fixes whatever is going on.

(Quick question, which may be out of place here. If I want to open a system file for editing obviously I need to do that as root. What’s the easiest way, graphically? I tend to browse to the file, then have to go up one level and open that directory as root, then enter the directory and open the file with kate. Is that okay? If I opened a terminal within the directory, I tried ‘su’ then ‘kate name-of-file’ but I had a warning that this wasn’t the best way to go about it. How *should *I use the terminal to launch kate as root? I have looked around the web for some way of adding to the right-click menu options such as ‘edit as root’ but couldn’t see anything.)

heres how i do it
enter password
>vi filename

if you dont know vi - leafpad can be substituted for vi or any editor like gedit - I use MATE for a desktop and lightdm for display manager since it looks like Windows XP or Vista and not like newer Windows 8 and 10 or a Cell Phone which gnome and kde are looking like.

When in KDE, you could do a command like

kdesu kate <file>


I ran into the problem yesterday evening, running 15.0 in a VM (virtual machine). I usually test updates there before trying them on my real machine.

Apparently it also doesn’t like something about the VM handling of graphics. And yes, others have reported a similar problem with nouveau.

For now, I can boot the previous kernel. There’s work in progress on a new kernel to fix the problem.

Same problem here running leap15.0 on a vmplayer virtual machine. For the moment I can use the machine booting in runlevel 3.
Waiting for a fix.
Thank you very much for the reports.

You should be able to boot the previous kernel, and that will allow a graphic session.

Waiting for a fix.

The kernel team is working on one.

Yes, I found the option in the grub sub-menu to boot the older kernel and it still works.

It’s always nice to know I’m not the only one having this problem, and that a fix is being developed! Thanks everyone for contributing.


Thanks for the update of today.
I can confirm that the new kernel works in the vmplayer virtual machine.
Thanks for the fast fix.

Thanks for the news.

Today I applied all the updates - the two that caused the problem (762 and 826) AND the new update (858).

Delighted to say that everything booted up properly and seems to be working fine!