Leap as a guest OS in Windows 10. Screen resolution setting.

Hello. Installed Leap on a virtual machine in Windows. I would like to run it full screen. I know I have to go to grub settings and somehow change resolution there. What are the correct commands?

You have to install inside the openSUSE the Guest-Addition of your Virtualbox-Version.

If you use KDE you can change your resolution with systemsettings5 inside KDE.

Too many detail not provided to answer your question.

What virtualization are you using?
What Desktop are you running?
What Display Manager are you running?
Or, are you even running a graphical environment when you’re fully logged in?
Are you viewing remotely or logged in to your HostOS and viewing your Guest in a windowed graphical console?

Before Plymouth, your screen resolution is manged by GRUB, but when your DE loads your DM and Desktop settings take over.
You’ll also have to describe what you mean by running your Guest “Full Screen,” you also might be looking at only needing to set your virtualization Guest setting.


Using HyperV
GNOME desktop
gdm display manager
graphical environment is there

After starting the VM and expanding to full screen I still see the smaller resoulution and the right click display settings give me only one resolution option. I think it is about changing the default resolution in the grub but I am not sure whicj commands to use.

Skimming a number of articles and postings,
Apparently what you’re seeing is a common Hyper-V problem.
The following TechNet Forum thread and its workaround to use a remote desktop (It recommends RDP but that’s not necessary) seems to be most often referenced by other posts.


Configuring the Display Resolution can be tried within a Guest, but it’ll only work to the limitations of the virtualization technology, and in this case there just seems to be a fundamental flaw using Hyper-V.

My personal favorite is to use X over SSH, AFAIK it will not matter what virtualization you use (The basis for the Technet workaround and my recommendation is that you bypass virtualization completely… The result would be the same whether you remotely connected to a virtual or physical machine so you only need to set up VNC and/or SSH server in your target machine). When you connect using X over SSH, the remote desktop should fill your SSH window… If you make it full screen or not.


FWIW, I encountered the same issue with running an openSUSE guest in VirtualBox (Windows 10 host). I created a minimal xorg.conf to set the desired display resolution (see below). I generated the modeline using cvt.

Section "Device"
  Identifier      "Configured Video Device" 

Section "Monitor" 
  Identifier      "Configured Monitor"
# 1920x1080 59.96 Hz (CVT 2.07M9) hsync: 67.16 kHz; pclk: 173.00 MHz
Modeline "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync

Section "Screen"  
  Identifier      "Default Screen" 
  Monitor         "Configured Monitor"
  Device          "Configured Video Device" 
  SubSection "Display"
    Modes "1920x1080_60.00"