Leap-42.3 - USB drive problems

  1. I have prior experience installing ISO files to a USB drive. I am following the instructions on the OpenSUSE page. Currently installed system is Kubuntu 17.04, which I don’t seem to care for. I want to switch back to using OpenSUSE, since it’s much better, IMHO.

  2. I have downloaded the following files:

  3. Both downloaded ISO files verify as OK.

  4. I used dd to install each to a separate USB drive using:
    dd if=/usr/local/Files:_ISO/openSUSE-Leap-42.3-DVD-x86_64.iso of=/dev/sdc1 bs=4M status=progress
    dd if=/usr/local/Files:_ISO/openSUSE-Leap-42.3-NET-x86_64.iso of=/dev/sdc1 bs=4M status=progress

  5. Install on the USB drives went slowly, but finished ok.

  6. Problems - when I try to boot using using either, the system hangs with:
    openSUSE-Leap-42.3-DVD-x86_64.iso: Prints this error message in upper-left corner of screen:

Missing OperatV2.0system

This is strange since I can mount and see the files got installed on the USB drive.

openSUSE-Leap-42.3-NET-x86_64.iso: Prints TWO flashing underbar symbols on the LOWER-left corner of the screen.

I’ve reformatted them several times, enabled the boot flag, and reinstalled using dd again. Still, the same exact problems are repeated.

Is there a way to verify the files as installed on the USB drives?

How can I go about diagnosing why I’m having these problems with the two USB drives? The drive with the DVD iso is newly purchased, the one with the NET iso is 2 years old, albeit has been reliable.

Any fix?

You need to write it to the device directly, not to the first partition.
I.e. these commands should give you a bootable USB drive:

dd if=/usr/local/Files:_ISO/openSUSE-Leap-42.3-DVD-x86_64.iso of=/dev/sdc bs=4M status=progress
dd if=/usr/local/Files:_ISO/openSUSE-Leap-42.3-NET-x86_64.iso of=/dev/sdc bs=4M status=progress

I’ve reformatted them several times, enabled the boot flag, and reinstalled using dd again.

There’s not much point in reformatting or modifying the boot flag before writing the image, as that will overwrite everything on the drive anyway (if you do it correctly :wink: ).

Ah, that’s it!

As many times as I have done this in the [distant] past, I don’t know how I managed to do that. It must be sleep deprivation.