Leap 42.3 is very very slow on a a minimal system.

I tried installing 64 bit Leap 42.3 on a system that has a dual core AMD64 and 1GB RAM, along with 500GB HD, the installation was fine, but it took nearly 1 hour just to boot in to the Gnome desktop (I tried KDE plasma, but the desktop refused to appear, and only showing the green light bulb and a grey square at the top left of the screen), when Gnome finally did appear the HD was solidly lite, what seemed a forever, so I tried to run the system monitor which took about half an hour to open, but when it finally opened, it showed the CPU usage as 100% on both cores, and the culprit was something to do with Gnome, (I’m not at the location and trying to remember what the problems were).

I thought it might be the computer specs, so, when I got home, I created an OpenSuSe VM in VB, on a 6 core 12GB system giving the VM 1GB and utilizing 2 cores, and a VHD of 500GB (to emulate to other system), as usual the installation went fine, but when it booted it took nearly an hour for the desktop to appear, so I waited for it to appear, then I shutdown the client (opensuse), then increased the RAM to 2GB (recommended for Leap 42.3), and re-ran the VM, and still the desktop took nearly an hour to appear, so I increased the cores to 4 and upped the RAM to 8GB, and as I guessed, it still took nearly an hour to boot into the desktop.

I use OpenSuSe CLI server mode on my server, and it works 100%, but install OpenSuSe with a GUI and that’s where it fails, both KDE and Gnome fail dismally, and yet Ubuntu, (With or without Unity), works super fast, to me, it seems the GUI for OpenSuSe, has not yet been perfected, hence I had no choice but to install Ubuntu with native Gnome on his computer and now he’s as happy as a sand boy.

The 1GB RAM is an issue, yes. AFAIK recommends are 2GB RAM. But, an hour is ridiculous. Have a look at

systemd-analyze blame

Post the output here, between CODE tags, the # in the layout ribbon