Leap 42.3 install DVD will not boot into the Installer

I am currently running openSUSE Leap 42.1 and I am tired of disabling repos, so I decided to do a fresh install.

I have downloaded both the DVD image and the net install image. Neither one will work. After telling my computer to boot from the disk through UEFI/BIOS, it will load GRUB fine. I choose Installation from the menu before the timer runs out. It goes through the first screen of loading stuff, into the screen with the green progress bar on the bottom. Then the next screen is where it encounters a problem. By the fifth or sixth line (which I cannot read because it is only on screen for a tiny fraction of a second) my screen goes black and the monitor instantly goes to sleep.

I have no idea what to do. I do not want to just upgrade my system because I tried that with a live USB stick I made, and I bricked the stick.

APU: AMD A10-7890K
2 Monitors (1 HDMI, 1 VGA)

Also, I have tried an internal and an external disc drive, and I have tried unplugging the HDMI monitor from the back of the tower.

It seems to be booting into the installer, but the video is messed up.

When you see the grub menu, select the line to boot to the installer. Then hit the ‘e’ key.

This should allow you to edit the boot command line.

Scroll down until you find a line that begins with “linux” (or probably with “linuxefi”).
When you are on that line, hit the END key to get to the end of the line (or scroll with arrows). Type in " nomodeset" at the end of the line.

Then CTRL-x to resume booting. That should get you into the installer. The graphics quality might not be the best, but it will be adequate. You can deal with that later (after install).

Thank you.

That worked perfectly. I now have a working fresh install.