Leap 42.3 does not start with graphical environment


I recently upgraded to Leap 42.3 and everything worked fine until the 1st (i think) time i shut down and started again. Graphical environment does not start, it only gets to Konsole and tty1. Not sure what this tty1 is. Any idea how to get the graphical enviroment back?


What Graphic Card?

What Driver for that?

Is drm-kmp-default installed:
as root:

rpm -q drm-kmp-default

package drm-kmp-default is not installed

how can i install this?

Hello, anyone?

sudo zypper in drm-kmp-default

But better provide more information, like what graphics card you are using, as you were being asked already.

sudo hwinfo --gfxcard

Onboard IGD
Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
Vendor: pci 0x8086 “Intel Corporation”
Subvendor: pci 0x1043 “ASUSTek Computer Inc”
Driver: i915
Driver info #0:
Driver Status: i915 is active

Ok, so it is intel.

Are you really sure that drm-kmp-default was not installed?
How did you check?

Did you try to install it?
(although if it worked in 42.2, that’s not really going to help…)

Can you please post the file /var/log/Xorg.0.log?

Re-activating this old thread, since I face the same problem andI find it hard to remember how I solved it (or partially solved it) last time. The problem started when I got an error of “Failed to load Kernel Modules”.
Following the discussion from above, the result from the command

rpm-q drm-kmp-default



From the PC I’m typing this on:

  Device Name: "Onboard IGD"
  Model: "Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x0402 "Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller"
  SubVendor: pci 0x1462 "Micro-Star International Co., Ltd. [MSI]"

Mine works fine with 42.3, with neither drm-kmp-default ***nor ***xf86-video-intel installed.

You were previously asked for Xorg.0.log. Again, your providing it might make it simple to suggest a suitable solution for you.