Leap 42.3 and NVIDIA GTX 1060 6GB - nvidia_modeset: Unknown symbol !

Good morning everyone.

Since I changed my video card I have had performance problems and no success in solving the problem. I bought an NVIDIA GTX 1060 6GB and both the Leap 4.4 kernel and the “nvidia” repository driver do not seem to work very well together.

What bothers these messages is “nvidia_modeset: Unknown symbol”.

dmesg | grep -i nvidia
    2.465985] nvidia_modeset: loading out-of-tree module taints kernel.
    2.465986] nvidia_modeset: module license 'NVIDIA' taints kernel.

    2.466719] nvidia_modeset: Unknown symbol nvidia_register_module (err 0)
    2.466727] nvidia_modeset: Unknown symbol nv_kthread_q_schedule_q_item (err 0)
    2.466738] nvidia_modeset: Unknown symbol nvidia_get_rm_ops (err 0)
    2.466753] nvidia_modeset: Unknown symbol nv_kthread_q_item_init (err 0)
    2.466757] nvidia_modeset: Unknown symbol nv_kthread_q_stop (err 0)
    2.466759] nvidia_modeset: Unknown symbol nvidia_unregister_module (err 0)
    2.466945] nvidia_modeset: Unknown symbol nv_kthread_q_init (err 0)

   12.964175] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:02.0/0000:08:00.1/sound/card1/input21
   12.964440] input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:02.0/0000:08:00.1/sound/card1/input22
   12.964685] input: HDA NVidia HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:02.0/0000:08:00.1/sound/card1/input23
   12.964926] input: HDA NVidia HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:02.0/0000:08:00.1/sound/card1/input24

   13.192373] nvidia-nvlink: Nvlink Core is being initialized, major device number 248
   13.193062] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  384.98  Thu Oct 26 15:16:01 PDT 2017 (using threaded interrupts)
   13.715456] nvidia-uvm: Loaded the UVM driver in 8 mode, major device number 247
   14.028648] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  384.98  Thu Oct 26 14:41:13 PDT 2017
   14.069620] [drm] [nvidia-drm] [GPU ID 0x00000800] Loading driver
               on the primary VGA device. The NVIDIA Linux graphics driver
   22.025001] nvidia-modeset: Allocated GPU:0 (GPU-23e06793-33f6-390b-2dc6-dac4a06cec6a) @ PCI:0000:08:00.0

According to research done here in the forum of opensuse and in the forums of archlinux and gentoo, I ended up solving a part of the problem of nvidia-uvm not loading right using the following configuration at boot:

splash=verbose quiet showopts enable_mtrr_cleanup mtrr_spare_reg_nr=1 nomodeset

I have already tried with the driver downloaded from the nvidia site (the famous “hard way”), and these problems disappear completely. On the other hand, Steam, for example, can not find the 32-bit libs of nvidia (which were installed without problem). I know I could change with “update-alternatives”, if these nvidia drivers came with this configuration ready and manually I was not successful. Anyway, the repository driver seems to be more complete, including up to the OpenCL libs.

Apparently the driver is working in most cases, Blender uses CUDA, KDE is stable, I can use NVENC etc. But these messages do not appear for example in Arch or Ubuntu.

For games, for example, XONOTIC, the game does not seem to flow like in Arch Linux.

Anyone have any idea why this problem happens and or give me a light on how to solve it?


Before you installed “the hard way”, you have deleted all Nvidia packages from the Repo and disabled the Repo?

All procedures.

With the “hard way” no error message in dmesg, just like when using Arch Linux, for example. But programs like Steam can not find the 32bit libs from NVIDIA, and they have been installed without problem, are in the folder and so on.

I know there is update-alternatives to configure the correct libglx, but the rules for choices only come in the nvidia repo package, so the hard way does not show any options there to choose libglx, and I was not successful in adding manually.

And checking with the DMESG of the Arch, I notice there are problems in opensuse with acpi, and they do not exist in Arch (probably because of the most current kernel).
I’ve already tried updating the kernel in opensuse leap, but after version 4.14.8, the nvidia driver does not compile anymore.

I’ve already tried updating the kernel in opensuse leap, but after version 4.14.8, the nvidia driver does not compile anymore.

That is known for 384.98. You have to patch or use 387.34 or 390.12 wihtout patching…

That is known for 384.98. You have to patch or use 387.34 or 390.12 wihtout patching…

Thank you for the tips!

387.34 is exactly the version I have downloaded.
I had tried the following:


I looked at the nvidia website right now.
Version 384.111 is available for download.

Where did you find this version 390.12?


Unfortunately, no method worked.

For now I’m going to stay in Arch Linux, which is running without problems.

When openSUSE 15 launches, I try again.

Thank you for your help.

I would not suggest trying 15.0 LEAP either. I work in a mostly Linux shop and my colleague has tried with Ubuntu 18.x as well. Both of us have had nothing but frustration. I can get the driver to work when doing it the “hard” way but only on the external screen and the refresh rate is abysmal. I have also tried with the opensource drivers and they just do not work. With Nvidia, as mentioned the external screen works (terribly) but the kicker is the laptop screen does not work. I have the one cursor in the upper left - in order to restore the laptop I have to move xorg.conf (created by Nvidia) to xorg.bak or whatever and then ctrl + backspace or init 3 && init 5 to get the laptop screen back.

If Lap top it is probably Optimus and requires bumblbee.

Uninstall any NVIDIA drivers and follow instructions here https://en.opensuse.org/SDB:NVIDIA_Bumblebee

Optimus is a special hybrid Intel+NVIDIA GPU hardware setup and the normal NVIDIA drivers simply won’t work without bumblebee

I have to move xorg.conf (created by Nvidia) to xorg.bak

Why do you create a xorg.conf by usind nvidia-xconfig?
I have never used this or create a xorg.conf by hand.
The Nvidia driver is working without that file.

And when you say, that it does not work, please show us your Hardware…