Leap 42.3 and Intel GMA 4500, desktop missing parts of icons, tearing, black areas etc

Leap 42.3 and Intel GMA 4500, desktop missing parts of icons, and letters, tearing, black areas etc

I have updated one computer a Dell Optiplex 760 from Suse 13.2 to leap42.3, i did not have any issues with the older version this latest one is really giving me grief, I have also tried a new install on a Optiplex 780 same graphics chip set and get the same issue.

Sometimes I can click on an icon and the program comes up and appears fine, then faults will appear like I have now of black areas appearing in the writing area.

I have read through a few posts on here and checked that I have the following:

I have also tried adding
Section “Device”
Identifier “Intel Graphics”
Driver “intel”
Option “AccelMethod” “uxa”

as a 20-device.conf in /etc/X11/xorg.conf.d Although why I did not understand why I did this.

The computers are getting to be very troublesome, can anyone give me some ideas to try.To see if I need some other libraries or if I have the wrong ones installed. I do not understand how it was fine in 13.2 but not now, unless I did something in 13.2 but have since forgotten?
I will appreciate your assistance.

The file needs to be called 20-intel.conf not device, also try sna not uxa and add TearFree as an option. Also ensure the package drm-kmp-default is uninstalled and blocked (zypper al drm-kmp-default)


I praise your knowledge Sir.

I read the other posts wrong so changed it to 20-intel.conf as you said, the file looks like this:

Section “Device”
Identifier “Intel Graphics”
Driver “intel”
Option “AccelMethod” “uxa”
Option “TearFree” “true”

Please let me know if you see any errors in that.

It is working, I can still try the sna instead of uxa, but is there a brief explanation on each and how would I know which is better, if possible?

I ran Yast, then Software management to remove drm-kmp-default. When I thought it had finished still used terminal as root to run zypper al drm-kmp-default.

It was difficult to see what was happening as I lost areas of the screen completely, so after 10 mins just rebooted.

It is, up to now, solid. This is on the computer that had the upgrade from 13.2 to Leap42.3.

I will power up and check/do similar on the other.

Many thanks.


Well sna should be the default, but if it’s working, leave as uxa :wink: The other option maybe setting the DRI option to 2 but only if you have blank area issues with some applications.

Enjoy and remember to have fun :slight_smile:

Err, just done the same to the Optiplex 780 same graphics and I have lost graphical interface, It just runs up in terminal.

So I log in with username and password. When I try to run startx, I got a message it could not find the console ( or similar). So in with vim, check out the 20-intel.conf, set to sna, save, no difference.

Rename 20-intel.conf to 20-intel.old and it goes into normal Gui screen, so now in to software manager and check I have the files I had on this machine.
Nope, missing xf86-video-intel and the associated files, download and install.

Rename 20-intel.old back to conf reboot and Yea graphical login.

Computers confuse me at times.

Ok so what is DRI option to 2, guess I will have to search for that, but I am going to keep fingers crossed it stays working without issues on both machines.

Thanks again.