Leap 42.2 Xen PVM screen resolution

I used xenfb.video=16,1440,900 in Grub kernel arguments string in Leap 42.1 PVM on Leap 42.1 Dom0
for virtual machine screen resolution 1440x900.
After upgrade this PVM to Leap 42.2 this method doesn’t work any more - screen resolution is 800x600
I tried to clean install new Leap 42.2 PVM - the same problem.
How can I change screen resolution in 42.2 paravirtual machine?

Setting screen resolution in GRUB may not be necessary if you also have installed a Desktop like KVM or Gnome. Do you have a Desktop installed or are you running either text-only “Server Mode” or MinimalX?

Although I usually use other virtualization, since numerous fixes were made to MinimalX that is now my preferred “Server,” it uses the same resources as “Server Mode” while providing a minimal graphical environment (I can’t remember if is Busybox or something else). Then I install and use arandr to manage my screen resolution.

TSU

I use gnome, but in display settings there is only one resolution - 800x600.
The described method with setting xenfb.video in grub worked fine in SLES PVMs and Leap 42.1,
but stopped working in Leap 42.2. Why?

Looks like the answer is here
Adding xen-fbfront.video=16,1440,900 to kernel parameters in grub instead of xenfb.video resolved the problem.
Means that since 42.2 the driver name is xen-fbfront.