Leap 42.2 Steam no Sound, skype no sound

Hello guys,

I just installed the new leap 42.2 and i had no sound in steam and in skype aswell.

Seems is missing a 32 bit lib from pulseaudio or something, is this maybe because in Leap 42.2 the 32bit libs are not supported anymore?, and how i can get sound again :smiley:

Thank you :slight_smile:

Just install the 32 bit version. They have 32 bit in the names

To get the name just start the app from the Konsole line to get the errors. There may be sever libs involved

I installed the same libs described here https://es.opensuse.org/SDB:Skype

In the Leap 42.1 Works perfectly but in 42.2 Still no steam sound, no skype sound…

Any more Ideas? :stuck_out_tongue:

Run from command line it will tell you what is missing

I once had a problem, when I used NTFS, and pulseaudio could not start properly. I started them from the terminal (or changed the desktop link) with “SDL_AUDIODRIVER=alsa steam” for example.

That page is out of date. For Skype you could try here: https://en.opensuse.org/SDB:Skype

Did you check pavucontrol to ensure pulse audio is configured properly for skype ?

SOLVED!!..

After installing alot of 32 libs my problem still not solved!!, making alot of clicks on KDE audio i figure it out!
I Checked aswell pavucontrol and all was fine!!

My problem was in the KDE volume control in the audio preferences when skype start a call it defines the principal channel as HDMI output instead my motherboard output audio, just click and define my mother board output audio as default solve my problem…

It happens the same on Steam games… so stupid thing… heheh maybe not a user-friendly KDE audio panel.

Thank you very much!! hope this help for future newbies with no skype - steam games audio… :slight_smile: lol!lol!lol!

On Thu, 17 Nov 2016 17:26:01 +0000, oldcpu wrote:
> That page is out of date. For Skype you could try here:
> https://en.opensuse.org/SDB:Skype
>
> Did you check pavucontrol to ensure pulse audio is configured properly
> for skype ?

I followed the instructions for Leap 42.1 in the link above and I have
been able to install skype on 4 different machines with Leap 42.2 too.

-G-

Hi Darklol,
Could you, please, explain to me what you meant by ‘KDE volume control’. I also ran into this problem and would like to solve it. However, I may have a completely different hardware configuration. I tried various avenues in YAST sound setup. I fiddled with the settings in ‘pavucontrole’ and in ‘Configure Desktop’ with Multimedia. I can’t find anything sensible to change in the KDE sound controle in my system tray. So I’m very keen to learn from you how you did it. When starting ‘skype’ from a command line I don’t get any messages of unresolved dependencies. I’d be grateful for your advice.

ok what is your default audio device as defined in Yast -Sound??? What in/out are you expecting to use? If a HDMI driver is set as first then all defaults go there

Did you install pavucontol. This allows easy assigning an out and input device.channel for each app. (do it with the program running to associate the channels to the program)

What sound devices are set in skype??

Do you get sound else where?? are all the volume controls set at a reasonable setting and not muted?

Sorry, I was away! TheYast sound configuration is

Not configure Broadwell-U Audio Controller
Not configured Wildcat Point-LP High Definition Audio Controller

I tried to configure the controller without it making an impact on skype.
I’m able to listen to everything I want on the browser ( not much) and also on the desktop (audacity) But skype remains mute except that when I try to connect I hear a very, very faint sound, hardly audible.

Yes, I’ve got pavucontrol installed. I use it to switch from built-in audio to bluetooth and to controle all the levels. The built-in HDMI post is ‘off’. All that works.
Pulseaudio is configured in skype and also started in Yast. All I want is that in addition to whatever I use sound for now already I can also use skype.It worked fine in Leap 42.1. Thanks for any hint!

If you can run a diagnostic script for us (with your PC configured exactly the way you believe it need be configured for this to work), that will yield information on your PC’s openSUSE audio setup and that might give us some hints as possibly this is a mixer misconfiguration.

With your PC connected to the internet, open an xterm/konsole and as a regular user send this diagnostic command in the xterm/konsole:


/usr/sbin/alsa-info.sh

select the SHARE/UPLOAD option when prompted, and then let the script run to completion. After it is complete in the xterm/konsole will be an address/URL location where the script output has been uploaded. Copy/paste that address/URL here and we will take a look at the output and see if it gives us any ideas.
.

Thanks for the help.
Here is the URL:
http://www.alsa-project.org/db/?f=a8b67246bd7e340db38815f6336b197700f9dcab

From that we can see that your openSUSE PC has 3 audio devices :

  • card-0 - HDMI - uses snd_hda_intel alsa sound module
  • card-1 - analog sound - uses another instance of the snd_hda_intel alsa sound module
  • card-2 - C110 USB webcam - uses the snd_usb_audio alsa sound module

Note that by default all audio will be routed to card-0 on your PC (ie your HDMI). Given your HDMI is not setup, this likely means sound by default for any application will go to the HDMI device. Recall that pulse audio in GNU/Linux provides the user the capability to direct sound an a per application basis to different sound devices, simultaneous.

Further note your openSUSE has two instances of the snd_hda_intel alsa sound module running. Nominally YaST Sound does NOT configure two instances of the same sound module well, so you can not rely on YaST sound to sort this.

In your PC’s openSUSE case, I believe when trying to get sound to work with openSUSE, you need to ensure that :

  • pulse audio is configured to output sound to card-1 (analog audio) and not to HDMI (which is the default as card-0)
  • (assuming you wish to use the webcam mic) pulse audio is configured to use your webcam mic

IMHO the best way to do this nominally with KDE or Gnome desktop is to install the application “pulse audio volume control” (pavucontrol) and configure it for use with Skype.

There is guidance on how to use pauvcontrol in this old blog post of mine here: https://forums.opensuse.org/entry.php/96-Pulseaudio-Basics-for-openSUSE-with-pavucontrol

Good luck.