LEAP 42.2 Removable storage media is not working.

hello.

I use gigabyte P34G v2. (laptop) I installed LEAP 42.2 here.
First, there is one problem. Removable storage media is not working.

Do not automatically mount the USB memory stick.
I do not automatically mount everything after checking “removable devices - system settings”.

I can access the file manager automatically when I attach USB memory or USB external hard disk.
I currently need to mount it separately from the console.

How can I automatically mount it?

have a nice day!

WHich desktop???

Normally I’d expect a popup of Device notifier which you can then use to call a relatted app and mount. It is not mounted by default. But how to fix is dependent on the desktop used

Thank you for answer.

I’ve mostly used Ubuntu so far. I have been using openSUSE because of the nvidia driver.

So I installed it by default. The display manager used KDE. I am simple.
I need to recognize when I install removable media (USB stick) after installing OS.

Currently, there is no response at openSUSE 42.2. I see it when I look at fdisk. The problem is that I can not automount.
I need to show it automatically in file explorer like Dolphin. There is no reaction at all.

What should I do?

Like gogalthorp already mentioned, I would normally expect USB storage media to cause a notification to be displayed. In the KDE system tray, right click on the little triangle to view ‘System Tray Settings’, and make sure that ‘Notifications’ is enabled. If that checks out ok, then the next step is to monitor udisksd output when the device is first plugged in. Open a terminal window and run

udisksctl monitor

then connect the device. Report back with the output (if any).

This should also show available removable devices…

udisksctl status

Also, what file system is reported by fdisk?

Assuming the device is /dev/sdb, it should be possible to mount via CLI

udisksctl mount -b /dev/sdb

It will mount under the /run/media/<user>/ directory.

Hint: bootable media might NOT auto-mount and cause no notification, but should be displayed and manually mountable (see post #4).
That might depend on desktop settings re. “what to do with removable media”.
Try connecting a “normal” data stick (i.e. with no bootloader installed) and see if it auto-mounts.
Gnome user here, sorry: cannot help with the KDE details to accomplish that.

Now, I will reply. Thank you for answer. However, removable media is still not recognized.

Replies like this won’t get you very far. We’re not over your shoulder, so we can’t see what you’re doing directly. I gave you some terminal commands to run, with the idea being that you would reply back with the output for others to review and advise further.

Searching for help on USB no longer mounting. Found this one.
Everything was working fine.
We lost power and the computer went down, when it restarted now the USB will not mount.
Any help is appreciated.

leap 42.2 -

Below are the results on my system to the questions above.

udisksctl monitor
Monitoring the udisks daemon. Press Ctrl+C to exit.
21:38:11.454: The udisks-daemon is running (name-owner :1.36).

When I removed the USB thumb drive it added:

21:38:47.449: Removed /org/freedesktop/UDisks2/block_devices/sdd1
21:38:47.482: Removed /org/freedesktop/UDisks2/block_devices/sdd

I plugged it back in and it did nothing. Unplugged it, and this time nothing changed.

dad@linux-hi7k:~> udisksctl status
MODEL                     REVISION  SERIAL               DEVICE
--------------------------------------------------------------------------
SAMSUNG HD161GJ           1118      S1V5J9CZ300518       sda     
CT120BX100SSD1            MU02      1527F009453E         sdb     
Crucial_CT250MX2          MU03      1614123EE61E         sdc     
hp        DDVDW TS-H653R  0E00      R0626GCZ23729900     sr0  

Wasn’t sure where it was to mount, tried sdd and sdd1, but nothing.
Will not mount the usb thumb drive.

thanks for any help.

You should start your own new thread with suitable title rather than tagging on to an old thread where the underlying cause of the issue may well be different.

will do, under hardware or another area?

Yes, hardware is ok.