Leap 42.2 quits booting after some tweeks and a shutdown

I have Leap 42.2 on my laptop and a clone on an older computer (testing Clonezilla) both by themselves and they work perfectly. I have been trying to install on a new computer alongside Windows and have had some interesting problems.
I get Leap up and running no problem, put in Nvidia drivers and restart, again no problem. Add some other programs and play with some multimedia, shut down and I cannot get back in without reinstalling. This is install #6.
I have boot set to verbose and it dies at login with “linux-r6yd login: 47.652075] sddm[2769]: segfault at 810 ip 000000000810 sp 00007ffe27ac1bc8 error 14 in sddm[4000000+6c000]” I have no clue what this means or what to do to get around it if it happens again.
Another note is that Windows will still boot from Grub without a problem. Although I am learning CLI I still know practically nothing about it.
One thing I have noticed is that Amarok was being a bit glitchy just before I shut down last time and lost boot ability, the time before that I was playing with Kodi and it was stalling.
Any suggestions would be helpful as I am getting to the point I do not want to add or touch anything when I get it running.

For starters, 42.2 is past its end-of-life. You should be on 42.3 by now.

If I had to guess, then my guess would be that adding other programs is causing a dependency conflict that leads to the problem you are having.

Thanks for the response. I’m figuring as much, with main guess being Amarok. Had a real problem getting it to play mp3 and then it tended to get worse at playing as it got down the playlist.
Know of a way to get logged back in without doing a reinstall?

At the login screen, try selecting the Icewm Session instead of KDE/Plasma 5. Since Icewm loads less software, you are less likely to run into an issue.

Don’t seem to have that option.
I have normal boot,
advanced options which includes a kernel boot and a kernel boot (recovery) both of which got to the same stall point,
Windows boot and
boots from a previous image? haven’t tried these yet when I’m in trouble

I wondered about that. It looks as if the failure occurs before you get to the point where you can make that choice.

boots from a previous image? haven’t tried these yet when I’m in trouble

If you are using the “btrfs” file system, then booting from an older snapshot might work. I can’t give you much advice on that, because I am not using “btrfs”. It should be a boot menu choice. I think it takes to a read-only system but you can then rollback to that snapshot.

7th install (sigh). Snapshots don’t boot either, oh well, keep pluggin away until I find the conflict.

So “sddm” - the display manager - is segfaulting.

When this happens can you still bring up a console by pressing Ctrl+Alt+F2 ?

If not, booting into non graphical mode (just add “3” to the grub load kernel line) should work and you should be able to use “yast2” (ncurses) to install a different display manager (e.g. lightdm).

In case booting into non graphical mode does not work boot the “rescue system” from the installation media, do a “chroot” and then use “yast2” to install a different display manager.



But …

Why are you using 42.2?

It is long since out of support, which does not help the matter.

Think about upgrading to at least 42.3 or even 15.0 (Currently Beta, but is very solid already and due for release only a few days away, now.).

I shall see if that works if I get into a spot again. Thanks

Just happen to be a slow mover, took me a while to move from 13.1. Plus I’m leary about new software after dealing with Windows and Mac, the only reason I’m not using XP is because I couldn’t find drivers for the computer I just built and Mac os has been going downhill since Jobs died IMHO.

Just a heads up, just in case others are having issues like this.
Upgrading to leap 42.3 didn’t change the conflict problem.
Adding myself to the Video group seems to have corrected the issue, go figure.
I guess G04 drivers are a bit dicey.
Thanks to those that replied.