Leap 42.2 Problem Updating - Oxygen-Sys-App-Error-Serious.ogg

I was updating my system this morning after several weeks being away and the update process stopped and the message

                    "Dependency resolution failed A package dependency could not be found.More information is available the detailed report." was displayed.

The detailed report yielded this statement “Oxygen-Sys-App-Error-Serious.ogg”

Like to know how to handle this problem with system updates since there are a number of uninstalled updates on account of this error. Any suggestion would be appreciated.

Please always accompany your explaining story with hard technical information.

How where you updating? Which tool, etc.

Henk…Thanks for your note. Responding to your question:

I was updating with YAST.

YAST indicated that there was a security update for ffmpeg. When attempting to update this package a long warning was displayed. I do not know how to post the warning after taking a snapshot (spectacle) of the warning. Would appreciate some direction on the method to display the warning.

I asked for a detailed description. “Using YAST” is not very detailed. YaST is used for many things.

I assume YaST > Software. Did you then use Online Update? That would explain you talking about a Security Update. But on the other hand ffmpeg is normally installed from Packman and Packman does not supply Security Updates.

And you can upload images to http://paste.opensuse.org (choose Image File from the Language menu upper right) and post the URL here.

Responding to your request for further detail. Steps outlined below:

A- Booted 42.2
B- Selected YAST from menu
C- Selected Software
D- Selected Online update
E- ran online update
F- Message displayed SECURITY “security update for ffmpeg”
G- selected “accept”
H- message displayed “security update for ffmpeg”
I- Warning message displayed. Message displayed in http://paste.opensuse.org/29336455

I would like to know what steps I need to take to resolve the issues enumerated.

As I am doubting about your Packman usage, please post the output of

zypper lr -d

zypper lr -d
Repository priorities are without effect. All enabled repositories share the same priority.

| Alias | Name | Enabled | GPG Check | Refresh | Priority | Type | URI | Service

—±--------------------------------±----------------------------------------±--------±----------±--------±---------±---------±-------------------------------------------------------------------------±-------
1 | Downloads | Downloads | Yes | ( p) Yes | Yes | 99 | plaindir | dir:///home/rjp/Downloads |
2 | download.nvidia.com-leap | nVidia Graphics Drivers | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.nvidia.com/opensuse/leap/42.2 |
3 | download.opensuse.org-non-oss | Main Repository (NON-OSS) | Yes | (r ) Yes | Yes | 99 | yast2 | http://download.opensuse.org/distribution/leap/42.2/repo/non-oss/ |
4 | download.opensuse.org-non-oss_1 | Update Repository (Non-Oss) | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/leap/42.2/non-oss/ |
5 | download.opensuse.org-oss | Main Repository (OSS) | Yes | (r ) Yes | Yes | 99 | yast2 | http://download.opensuse.org/distribution/leap/42.2/repo/oss/ |
6 | download.opensuse.org-oss_1 | Main Update Repository | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/leap/42.2/oss |
7 | openSUSE-42.2-0 | openSUSE-42.2-0 | No | ---- | ---- | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-HL-DT-ST_DVDRAM_GH24NSC0_K13EAFG2420 |
8 | opensuse-guide.org-repo | Libdvdcss Repository | Yes | (r ) Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_42.2/ |
9 | packman.inode.at-suse | Packman Repository | Yes | (r ) Yes | Yes | 99 | rpm-md | http://packman.inode.at/suse/openSUSE_Leap_42.2/ |
10 | repo-debug | openSUSE-Leap-42.2-Debug | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/distribution/leap/42.2/repo/oss/ |
11 | repo-debug-non-oss | openSUSE-Leap-42.2-Debug-Non-Oss | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/distribution/leap/42.2/repo/non-oss/ |
12 | repo-debug-update | openSUSE-Leap-42.2-Update-Debug | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/update/leap/42.2/oss/ |
13 | repo-debug-update-non-oss | openSUSE-Leap-42.2-Update-Debug-Non-Oss | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/update/leap/42.2/non-oss/ |
14 | repo-source | openSUSE-Leap-42.2-Source | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/source/distribution/leap/42.2/repo/oss/ |
15 | repo-source-non-oss | openSUSE-Leap-42.2-Source-Non-Oss | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/source/distribution/leap/42.2/repo/non-oss/ |

Oh please in the future use CODE tags around copied/pasted computer text in a post. It is the # button in the tool bar of the post editor. When applicable copy/paste complete, that is including the prompt, the command, the output and the next prompt.

You have Packman. But I doubt you did the Vendor switch to it.

zypper dup --from 9

After that check again.

Henk…Your suggestion worked. Using zypper dup --from 9 made the problem go away. After the line of code was complete I rebooted the machine from Konsole using shutdown -h now. When the system was restarted there was no upgrade suggested and hence no error to report. Thank you for your help. In the future I will post questions with complete technical detail…newbuilder

Nice it worked.

Remember (for a next install or a move to a newer openSUSE version) that when you add the Packman repo to get full multimedia support, this vendor switch must be done.