LEAP 42.2 only loads my root file system as Read only and so wont autoboot in Gnome.

Hi all,
I have been using Leap 42.1 and Leap 42.2 for over a year now. From early on I have had issues with Plymouth not working satisfactorily, but I got a stable boot by sticking to Kernel 4.4.38-14-default, trying any other Kernel would dump me to Plymouth Panic mode.
However things have recently changed somewhat as now the system will not boot to Gnome automatically, instead it dumps me to the console for login.
I enter my user account and password and then I enter su and the root password. At this point I mount the root file system as RW using **mount -o remount,rw / **which then kicks the system into action and the system proceeds to launch Gnome in my own user account.

So the source of the problem seems to be that the system is mounting the root file system as read only which is preventing Plymouth/intrid from completing the boot. These processes are obviously still loaded in the background waiting for write access to my root partition.

Basically whatever is going on has been with me since I upgraded to 42.2, but I cludged it by using kernel 4.4.38-14-default. This no longer works.
I suspect this is quite a complex problem underneath it all and have no clue what to do to solve it.


Start by booting with the install DVD or another boot disk and run fsck on all your partitions, but primarily on your root partition.

If no boot disk, then instead add:


to the boot command line.

To do that, boot and when you see the Grub menu, hit the “e” key, which will put you in edit mode. Scroll down to the line that begins with linux, hit the End key to get to the end of that line (it wraps), add a space and add the rd.break option.

This should get you to the CLI where you can:

umount /dev/sdXN

where the X is the drive – a, b, c, or ? – and N is the partition (as in sda1, sda2, sdb1, etc.)

fsck -f /dev/sdXN

OK thanks for that, but it didn’t help.


I turned off the splash to see if I could get a bit more information.
I get a 1.30min time delay at the start of boot with the message:

A start job is running for dev-sdb5\x3dsilent.device

sdb5 is my main system partition.

I was also seeing the error

Dependency failed for resume from hibernate

I suspect that the systmd has got confused over various legacy partitions that have lingered through multiple upgrades and disk modifications.
Is it possible to simply reset the boot process to look just at my known main OS partition ?


It seems its a pam authentication issue:

Feb 21 17:38:07 Huawei-HG658c-instalacion gnomesu-pam-backend[10270]: The gnome keyring socket is not owned with the same credentials as the user login: /run/
Feb 21 17:38:07 Huawei-HG658c-instalacion gnomesu-pam-backend[10270]: gkr-pam: couldn’t unlock the login keyring.