Leap 42.2 Kmail 5 settings

I have had one or two problems getting this to work with my isp. I currently have one account receiving email via POP3 on port 110. I believe that this one isn’t encrypted. I’ve used this set up for a long time. My isp now offers an alternative with ssl on port 995. I’m not at all sure what to select in the settings. The button to get info from the server has never ever worked for me on any version of kmail.

The working pop3 settings are no encryption, apop and the usual email address and login password on port 110.

:’(I’ve tried all sorts but no luck. Even had the account barred down to too many failed attempts at logging in.

I’ll probably have the same problem when I come to sending emails on smtp port 587 for unencrypted or ssl. I’m pretty sure I used another port in the past.

;)I’ve only just upgraded from 12.3. Long story.

John

You only need to change the 2 things you mention, everything else can remain the same.
Go to Settings > Configure Kmail. Click on Accounts (under Identities, left side), select the appropriate account and click Modify on the right. Go to the Advanced tab at the top and choose the SSL/TLS radio button and type 995 in the box below. OK and it’s done.
Similar for sending. I think you choose SSL or TLS then type in the 587 and OK that.

That’s what I thought Pete. I have tried that one before leaving the Authentication as APOP It just hangs and generates an error after the server time out period. Some others arrangement come up with a terminated immediately message. The pop3 account that is working is set for APOP.

I tried interogating the server manually in the console to see if that revealed anything.

This


openssl s_client -connect pop.tiscali.co.uk:995

Produced lots of lines the only ones that may be relevant were these


No client certificate CA names sent
---
SSL handshake has read 2681 bytes and written 607 bytes
---
New, TLSv1/SSLv3, Cipher is RC4-SHA
Server public key is 2048 bit
Secure Renegotiation IS NOT supported
Compression: NONE
Expansion: NONE
No ALPN negotiated
SSL-Session:
    Protocol  : TLSv1
    Cipher    : RC4-SHA
    Session-ID: 17679B58502D0F00000000000006EEF1000073B5
    Session-ID-ctx: 
    Master-Key: 3BDF77859D096E650A501279E3168C2B64B7D4082F877CCA2E761D8EFFD66DD546DAF633CD471963A11432FBC2ABC934
    Key-Arg   : None
    PSK identity: None
    PSK identity hint: None
    SRP username: None
    Start Time: 1486579479
    Timeout   : 300 (sec)
    Verify return code: 0 (ok)
---
+OK POP3 server ready <C8E1995F6EFD4B06E4830828B182A8E76F2DE407@mail.svcgb1.int.opaltelecom.net>
closed


There may be some better way of obtaining the info needed. The above is all I could find on the web.

John

I just checked that the passwords I am using are correct via tiscali’s web interface to the accounts. So that rules that one out.

John

I’ve tried all of the options and none of them will log in. I suspect it should be set for APOP authentication and KMail sets the correct port automatically when ssl/tls is selected.

Playing around with the package certain factors about it’s behaviour leave me thinking that the whole thing is rather flaky and in need of more work. Some of the oddities are in the account settings area.

The email server is part of the TalkTalk group. One of the UK’s larger isp’s so in real terms it should work with it.

John

I installed Sylpheed. It’s been around for some time and I think evolved slowly. No problems at all. No need to set port or protocol. Just use SSL etc. I used the one click install off opensuse software search. Looks like it’s an unsupported gnome package.

Very similar in some ways to kmail3. HTML can be decoded but no option to load the links - :wink: I do sometimes want to let them know I have read it.

If an image is sent in a mail it can be displayed and also dragged out or saved.

The mail filtering is the same as kmal3 plus a bit. There didn’t seem to be a drop through to route anything left to a separate box but. I left the contains field blank on the last filter and that has directed any remaining emails to the right box - so far anyway.

It wont send html emails but that has never caused me a problem but it would be handy at times.

I’m not sure where you get the APOP from, mine’s just POP3. I’ve checked tiscali set up and what I said in my first response should work according to their set up instructions.

TalkTalk’s help for tiscali users doesn’t mention their pop3 email server any more. It uses port 110 and is still there as the email address that I mentioned that was working was using that server using APOP authentication. As far as I know the pop3.tiscali… doesn’t offer ssl. There other one pop.tiscali… does and is on port 995 as it should be but apparently some isp’s may use different port addresses. As I couldn’t get it work on that server I can only assume that APOP should be used for authentication. Most of the other’s kmail offers just results in an immediate disconnect at the server end. Kmail otherwise just hangs but does switch automatically to the correct port when ssl is selected . It has also come back with the message that the server says it supports tls/ssl in manner that suggests that the server is faulty. That and several other things don’t always happen though which is why I mentioned that the software looks flaky to me. It could be that once something like this has gone wrong it doesn’t recover - even when shut down and restarted. I tried the lot and noticed one or two other aspects that miss behaved.

All I can add is that sylpheed hasn’t had any problems configuring for the server… Nothing to select setting up either other than to tell it to use ssl. It picked the rest all on it’s own.