LEAP 42.2 KDE how to not get the black screen after update

I really wanted to have OpenSuse 42.2 Leap running with KDE but asap I run the update KDE and OpenSuse is dead.

In my opinion, not ready for production and not well maintained either.

I have a NVIDIA GT730 Graphic Card and installing NVIDIA works fine until I reboot to the blue ehm black screen of death.

I remember those things when RedHat came out on a CD in a PC-Magazine, surprised to see this a (stable/unstable) distro.

Reading my post, I hope you can imagine how much steam of disappointment for my wasted life time I have.

Some one with some ideas?

I have the same graphic card as you and opensuse kde (or plasma5 as it is now called) works fine for me. I don’t use opensuse 42.2 but the rolling distribution tumbleweed.

Have you installed the nvidia driver or are you using the open-source version?

When it is installed it works with the open source driver, I have then installed the NVIDIA drivers and it is fine, asap I run the updates the reboot screen stays black:O

Bytheway, I am now running OpenSuse 42.2 Gnome 3 and that just went fine, even after the updates.

Is there a new iso file to download maybe a little younger avoiding this pitfall?

How was the NVIDIA driver installed? If the hard way you must reinstall after any kernel update

Nope, the easy way. Will attempt a net install and see if I don’t pull that nasty bit of software doing it to me :open_mouth:

No, there will be no “more recent” ISO. There is just one Leap 42.2 ISO, by definition.

And a net install wil bring you nothing more then the ISO and a YaST Online Update afterwards brings you. It is just a different way to reach the same situation…

You are right, I just wasted another 2.5 hours for this junk. It reminds me back in the days when Redhat came out as a CD in a PC Magazin and we had 8 needle printers.

OpenSuse KDE is still born and by far not worth any efforts if the OpenSuse Team rolls out such a junk ready for production.

Not bothered anymore, I think my experience says it all. And the interest from the OpenSuse Team to fix this shows it all.

Back to Arch, Arch has never let me down.

The issue seems to be in KDE Plasma and KWin. A resolution does not appear to be forthcoming.
Running another desktop works OK, eg xfce, lxde, mate, … Many based on Gnome or very lightweight.
A shame. Always liked KDE which is now unusable. Maybe will have to drop opensuse too :frowning:
Still running 13.2 for main use. (42.2 on experimental machine only.)

I didn’t get that problem at any other distro.

I am with Arch as my main drive and KDE 5.8 and all is fine.

42.2 on experimental machine (acer aspire netbook with atom n550) seems to run “OK” with limited display lagging if compositor is not launched at startup (system settings - display and monitor - compositor). Opens browser, plays movies etc but not rigorously tested.