Leap 42.2 - first imperssions after the upgrade from Leap 42.1

Hardware: AMD A10-5750M APU with Radeon™ HD Graphics – 8 GB RAM – Lenovo G505s Laptop – dual-boot to Windows 8.1
Network Manager; KDE Plasma 5 Desktop; a single ext4 partition.
Boot performance (battery – charger was not plugged in):

Startup finished in 1.953s (firmware) + 9.082s (loader) + 3.470s (kernel) + 7.179s (initrd) + 6.748s (userspace) = 28.433s

          2.978s apparmor.service
          2.234s systemd-journald.service
          1.463s dev-sda10.device
          1.256s systemd-journal-flush.service
          1.176s postfix.service
          1.128s display-manager.service
           700ms SuSEfirewall2_init.service
           537ms SuSEfirewall2.service
           388ms mnt-Windows.mount
           288ms systemd-tmpfiles-setup-dev.service

Yes, the initial boot: was slow but, subsequent reboots are as above.


  • All the user icons appeared in the SDDM login display – better than the Leap 42.1 graphics.
  • KDE in general is behaving better and nicer and more responsively than the Leap 42.1 version – I may even begin to tolerate Breeze (at least until the openSUSE Air and KDE Plasma 5 Oxygen options become stable enough for general use).

General system (non-GUI):

  • Suspend works as it should do – suspend and the Laptop lid switch work even from the SDDM login display.
  • Did I experience some resolvable system issues during the upgrade?

Sadly yes, but I’ll note them in another entry to this thread.

[HR][/HR]13.2 and Leap 42.2 running on 64-bit AMD 4-Core CPUs with AMD Graphics

Upgrading via the Leap 42.2 DVD resulted in the upgrade procedure complaining about some Samba package conflicts which were resolved after Leap 42.2 booted by the YaST Online Update Dialog.

In addition there were several orphaned packages left over after the upgrade completed.

These issues are being tracked by the openSUSE Bug 1010917.
[HR][/HR]I’ve also experienced a KDE Konsole crash (Segmentation fault) which has been reported in the KDE Bug 372620.

I did a clean install of 42.2 on my main desktop.

I did an upgrade of RC2 on another computer. For the upgrade, I used the DVD installer (on a USB) as a local repo, and then did “zypper dup”. It got most packages from the local USB.

The transition to 42.2 went quite smoothly – perhaps my best linux install experience ever.

There were, however, a couple of glitches worth mentioning:

1: My main desktop, where I did a clean install, also has Windows 8.1. It’s a UEFI machine. After the install, then running 42.2 for a while, I tried to boot Windows. There was no menu entry to boot Windows.

I then ran “grub2-mkconfig -o /boot/grub2/grub.cfg” to refresh the boot menu. After that, there was an entry for Windows. I’m not sure why that menu entry was not added during the install.

2: On another computer, when I cold boot the computer automatically powers off. That does not happen with 42.1 or any other system. If I boot 42.1 first, then rebooting to 42.2 is fine. Maybe something in the hardware isn’t properly warmed up on a cold boot, and the kernel for 42.2 is particularly sensitive to whatever it is.

I made clear installation. KDE seems to me more polished.

I noticed that something wrong is with automatic updates. There was not problem on Leap 42.1. Usually several times during the day.
But it is out of order on 42.2. It gives me still information, that I am offline. Strange. So I must click Check updates button and package updates appear.

I think you are using WiFi. It makes a WiFi connection after you login. But it has started the updater before that connection is made.

I am confused, here. Do you mean, when you reboot the computer?

My understanding of a cold boot is that you completely power off the computer. Then, with the power button, boot the computer from complete off, or cold.

So, could you un-confuse me, here? Did I misread something?

I upgraded from 42.1 to 42.2 on release day without any major issues.

Stuff that got better:

  1. Boot time, on my initial 42.1 system I had about 30 seconds boot time that increased to 50 seconds and stayed there, not sure why. Now I am back on about 28 seconds with 42.2. Though I am an Xfce user on a SATA drive.
  2. Horizontal scrolling with the track point works by default and that on an Xfce desktop. I use a Thinkpad T400. On Debian I even have to configure regular scrolling with the track point and the middle button.
  3. Closing the lid no longer suspends my laptop. It does what I specified in the power management settings, that is do nothing.
  4. Fonts look crispier even though I still apply freetype from third party repositories. But yes, fonts improved with or without personal tweaks.

Minor issues:

  1. The default Gtk theme in LightDM looks a bit strange or maybe it is my eyes.
  2. I have an error message on boot but it does not affect anything. Has to be one of those useless kernel messages.

That’s about it. I am a happy camper.

Yes, that’s about what I meant.

In more detail:

I switch on the computer. It has been off for a while. I select opensuse 42.2 in the grub menu. It starts to load the kernel, and then nothing – the computer has powered off. I try again. This time it completes booting. But at around 2 minutes into the KDE session, nothing – the computer has powered off. That was yesterday. After that, everything was fine for the rest of the day.

I’ve noticed the same on a couple of other occasions, but I wasn’t checking as carefully so I wasn’t sure if I had I had accidentally hit the power button. But this time I was watching closely enough to be sure that it wasn’t me that powered it off.

Today, I booted into 42.1 (still on the same computer, different disk area). No problem at all. I ran updates. Then I booted into 42.2. Again, no problem at all. So this only seems to happen when my first boot after power on is to 42.2. And if the chips are sufficiently warmed up, it will probably be okay after a brief shutdown and reboot. I am only seeing this on the one computer, and it is a 9 year old machine. So it near the end of its useful life. But I only see this power off with 42.2. I probably should give Tumbleweed a try to see what it does. But Tumbleweed doesn’t like the nvidia graphics (nor do 42.1 or 42.2 actually).


Thanks for clarifying, Neil.

I’ll be watching to see what happens with Tumbleweed, so do let me know.

Yes you are right. I use wifi connection on notebook. But there was not problem related automatic updates with Leap 42.1 despite using wifi.
I also have a look at virtualbox machine Leap 42.2. There is connection simulated like wired connection. The same problem, the same note that your system is offline.

hi would you please tell me your solution to the font problem ???
i’m having some really hard time with my screen and the new fonts please take a look at this thread

There is no problem with the fonts. It is just personal preference. I never liked the default Opensuse setting.
I use this repo for freetype2:


And of course I use some settings like antialiasing, hinting set to slight, subpixel rendering with RGB and lcddefault.

People actually did complain about that problem with 42.1. But it depends on your WiFi configuration.

In NetworkManager, edit connections, you can configure it so that the WiFi key is stored unencrypted and available to all users. Once that is done, you can then set the connection to be shared with all users. With those changes, the WiFi connection is established before you login, and then updating should not give those messages.

Getting the WiFi setting right is a bit complex, because of the defaults that KDE decided to use.

Thanks for your effort and explanation. But this is not wifi problem.
I made simple test. I turned off notebook, connected network cable and turned on notebook. After KDE session login there was the same information “Your system is offline”.

I remember that there were similar problems with 42.1. It takes about one month till it was solved.
But now it seems that I am alone who met this problem.
I am thinking about going back to 42.1 and waiting for a while.

Then the likely reason is that it didn’t even check for updates. :wink:

The default is to check once per day, i.e. every 24 hours.
And it doesn’t explicitly check on login any more AFAIK, that actually was a bug in 42.1 that got fixed…

I am back on 42.1. There is update check on each login. There is not difference between wifi or wired connection.
Software updates inform me “Your system is actual”.

Please, can somebody confirm same correct behaviour of Software updates under 42.2?

Yes, there is.
And that’s actually a bug, as mentioned, though Apper before behaved the same (and quite a few people complained about that).

There is not difference between wifi or wired connection.

No, but if the connection is not up yet when it checks, it will also say “offline” (until it checks again).

This is actually because it gets the network status from PackageKit.
But on openSUSE, PackageKit is normally not running (because it blocks zypper and YaST), it will only be started when the applet actually checks for updates and quits again afterwards.

If PackageKit is not running, it cannot detect the network state (and report it to the applet) either…

The only difference you see IMHO, is that in 42.1 it checks for updates on every login (and actually every hour), while on 42.2 it actually respects the settings and only checks every 24 hours.

Please, can somebody confirm same correct behaviour of Software updates under 42.2?

I can confirm that the latest plasma5-pk-updates from KDE:Frameworks5 (42.2 has exactly the same version) works correctly here on 13.2.

It is just a slim frontend for PackageKit anyway, so if somethings not working, it’s more likely a problem there.
Did it check for updates when you clicked on the button? Did it still say “offline” afterwards?

Manual update check via button works. There is “Your system is actual” after this.
But when I checked Software updates status about hour later there was again “Your system is offline”.
I plan to create virtualbox openSUSE 42.2 machine and check that once a day update.

What I did:
fresh install to new, unused partition, keeping /home from existing install (13.1)

The good: It installs and boots.

The bad:
very slow - I can see windows redrawing/mouse location updating. Trying to use Krita is simply pointless.
install of ntp fails (no ntp daemon running). This blocks install of a further 100 updates
Yast/install recommended updates fails without any warning
shutdown doesn’t power off

It’s done something to /home, so, while I can boot back into 13.1, I get a blank screen trying to log into existing user.


nvidia graphics?
Then make sure that Mesa-dri-nouveau is installed, or you’ll use software 3D rendering (which is indeed slow).
Or (even better) install the proprietary nvidia driver.

install of ntp fails (no ntp daemon running). This blocks install of a further 100 updates

I don’t see how “no ntp daemon running” would make the ntp update fail.
Can you provide the output please?

Though it’s probably better to open a new thread to solve your problem(s).

And it shouldn’t block the other updates either. Just deselect it.

Yast/install recommended updates fails without any warning

What does “fail” mean here?