Leap 42.2 Firefox has no scroll bar, recent drop-down arrow, or checkboxes

I’m running Leap 42.2 and the Firefox install it comes with has no scroll bars on any website. It also does not show the little down arrow in the recent list, nor does it show any type of check-boxes on any site.

I recently installed all available updates and everything suddenly started working fine. I have since rebooted and now it’s back to no scroll bars, etc.

How do I get the scroll bar and check-boxes back. I’ve been using Firefox for years and I’ve never seen this before. It has to be a config issue since it worked for one day after the updates until I rebooted.

Thanks!

First, create a new user, then test as that new user.

Created another user and and tested with that account. It does exactly the same thing.

sounds like a gtk issue
tell us your repo list

zypper lr -d

did you recently install an app with the 1-click installer?
as that’s the way a lot of users add wrong repo’s and mess up their system.
does it happen only with Firefox, have you tried different gtk2 apps (atm I can’t think of any I’m not sure if gimp is gtk2 or gtk3)

I’m sure I’ve used a one-click install, but it’s been doing this since I installed. I also did a clean install; no upgrade. I just assumed it was some default setting that people prefer that’s now considered “intuitive”. :slight_smile:

Thanks for the help!


#  | Alias                            | Name                                    | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                      | Service
---+----------------------------------+-----------------------------------------+---------+-----------+---------+----------+--------+--------------------------------------------------------------------------+--------
 1 | http-ftp.gwdg.de-0929a368        | Packman Repository                      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_Leap_42.2/            |        
 2 | http-opensuse-guide.org-2a01c1bb | libdvdcss repository                    | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_42.2/                       |        
 3 | openSUSE-42.2-0                  | openSUSE-42.2-0                         | Yes     | (r ) Yes  | No      |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-HL-DT-ST_DVD+_-RW_GH70N_K1LB76E4636   |        
 4 | repo-debug                       | openSUSE-Leap-42.2-Debug                | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/42.2/repo/oss/      |        
 5 | repo-debug-non-oss               | openSUSE-Leap-42.2-Debug-Non-Oss        | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/42.2/repo/non-oss/  |        
 6 | repo-debug-update                | openSUSE-Leap-42.2-Update-Debug         | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.2/oss/                 |        
 7 | repo-debug-update-non-oss        | openSUSE-Leap-42.2-Update-Debug-Non-Oss | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.2/non-oss/             |        
 8 | repo-non-oss                     | openSUSE-Leap-42.2-Non-Oss              | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.2/repo/non-oss/        |        
 9 | repo-oss                         | openSUSE-Leap-42.2-Oss                  | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.2/repo/oss/            |        
10 | repo-source                      | openSUSE-Leap-42.2-Source               | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/42.2/repo/oss/     |        
11 | repo-source-non-oss              | openSUSE-Leap-42.2-Source-Non-Oss       | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/42.2/repo/non-oss/ |        
12 | repo-update                      | openSUSE-Leap-42.2-Update               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.2/oss/                       |        
13 | repo-update-non-oss              | openSUSE-Leap-42.2-Update-Non-Oss       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.2/non-oss/                   |

your repo’s look fine
could be a video card issue what desktop and what video adapted/driver do you use?
try and run an update

zypper up

Thank you for this! It is indeed a video card issue. I’m running a Dell E520 with an NVidia Quadro FX 1700. I blacklisted the nouveau driver and suddenly I have drop-down arrow, scroll bars, and check-boxes. I downloaded the latest proprietary driver, and after fudging around with it for the last few evenings, it still won’t install. I’m getting the “no module_format” error.

I just discovered that the reason is that all the kernel devel packages suse provides are for 4.4.36-8.1, while the running default kernel is 4.4.27-2.1. Apparently, they don’t ship configured kernel source for the installed version, and the pre-built 4.4.36-8 kernel is for “debug” purposes?

It’s kind of sad. I’ve had this machine for about 8 years and I’ve run suse on it since the beginning. I remember when suse shipped with everything you needed right out of the box. I just upgraded from 13.2 and the nvidia drivers worked flawlessly. It looks like I now get to spend several more evenings building and rolling kernel versions until I can find some combination that works.

Thanks for the help!

Which version did you download from where, and how did you try to install it?

Better use the repo:
https://en.opensuse.org/SDB:NVIDIA_drivers

I just discovered that the reason is that all the kernel devel packages suse provides are for 4.4.36-8.1, while the running default kernel is 4.4.27-2.1. Apparently, they don’t ship configured kernel source for the installed version, and the pre-built 4.4.36-8 kernel is for “debug” purposes?

The latest kernel in 42.2 is indeed 4.4.36, there have been official kernel updates for 42.2 already.
If you are running 4.4.27, you are running an old/outdated one.
Did you ever update your system? Did you reboot afterwards?

Anyway, the kernel devel packages are available in all versions that the kernel is available.
Click on “Versions” in YaST to see them, the list only shows the highest version.

You don’t seam to have the nvidia repo but you blacklisted noveou I don’t get it why, you’re probobly using the old nv driver
Add the nvidia repo and pull the nvidia driver, do not blacklist noveou the nvidia rpm will do that automatically
as far as I can tell the geforce equivalent of your gpu is GeForce 8600GT I think the G03 driver supports it but I’m not quite sure, I know there was an issue with the G02 upstream I don’t know if it was fixed or not but running
zypper install-new-recommends will install the driver for your hardware so do

zypper ar -f ftp://download.nvidia.com/opensuse/leap/42.2/ nvidia
zypper ref
zypper install-new-recommends

you can do copy/paste with the above command

edit.
I just checked the G03 driver and it says

NAME: x11-video-nvidiaG03
VERSION: 340.101
RELEASE: 5.1
SUMMARY: NVIDIA graphics driver for GeForce 8xxx and newer GPUs

so you can install the G03 driver which is quite good (I’m using it)
do this (or the above not both)

zypper ar -f ftp://download.nvidia.com/opensuse/leap/42.2/ nvidia
zypper ref
zypper in x11-video-nvidiaG03

that should install the 340.101 nvidia driver and you can use hardware acceleration inc. 3D

When installing the proprietary nvidia driver, the installer requires you to black-list the nouveau driver.

I found where to install the 4.4.36-8.1 kernel and now the nvidia installer runs perfectly. So as I post this I have all the little drop-down arrows and scroll bars. I’m not sure why it isn’t listed simply with all the other software. I found it under the 4.4.27 information. I tried the G03 driver last night but all I get is a black screen. I would really rather run something that is suse specific, but at this point, I’m not going back. At least I get the nifty nvidia tool to configure all my settings. :slight_smile:

Thank you all for the suggestions and help! I never would have guessed that firefox weirdness was the display driver.

That’s only true if you use the run installer, using the rpm it’s not needed, it might even break something, it’s good that you fixed things