LEAP 42.2 32GB Low Memory

Hi Folks ,

do have a PC here with 32GB of ram ,i run Android Studio, Net beans and Google chrome with some other applications all at same time , which should not be an issue as i have 32Gb of physical ram ,the issue is that i get android studio to complain out of memory ,net beans hangs out , Google chrome wont open any new taps/pages , why is that and can i get the most out of my ram here and have my applications rum smother please ?
here is the result of : free -m

free -m
             total       used       free     shared    buffers     cached
Mem:         32097      17114      14982        678        332       6690
-/+ buffers/cache:      10092      22005
Swap:        40961          0      40961

You use no swap it is 0

You have 6 gig in cache Note that Linux does not like unutilized memory and will use it for cache if no other process needs it that cache will be dropped if some other process needs space. Then you have 15 gig free.

Why are you worried LOL

Have no idea about chrome don’t use it but there is plenty of memory to be used so not a memory problem

no whenever i try opening new terminal i get this before it gets ready to be used

bash: fork: retry: No child processes 
bash: fork: retry: No child processes 
bash: fork: retry: No child processes 
bash: fork: retry: No child processes 

is there a way to utilize memory ?
is there a way to increase performance in my case | intel 7600k ,GTx970,32GB ?

This might be a process limit issue (which can be adjusted if necessary). How many processes are being run?

ps hax -o user | sort | uniq -c

By default user processes are limited to 1200

ulimit -u

That can be changed with an edit to /etc/security/limits.conf

For more info

man limits.conf

If your system hangs at times this comment from the arch wiki may be of interest.

Virtual memory

There are several key parameters to tune the operation of the virtual memory (VM) subsystem of the Linux kernel and the write out of dirty data to disk. See the official Linux kernel documentation for more information. For example:

  • vm.dirty_ratio = 3

Contains, as a percentage of total available memory that contains free pages and reclaimable pages, the number of pages at which a process which is generating disk writes will itself start writing out dirty data.

  • vm.dirty_background_ratio = 2

Contains, as a percentage of total available memory that contains free pages and reclaimable pages, the number of pages at which the background kernel flusher threads will start writing out dirty data. As noted in the comments for the parameters, one needs to consider the total amount of RAM when setting these values. For example, simplifying by taking the installed system RAM instead of available memory:

  • Consensus is that setting vm.dirty_ratio to 10% of RAM is a sane value if RAM is say 1 GB (so 10% is 100 MB). But if the machine has much more RAM, say 16 GB (10% is 1.6 GB), the percentage may be out of proportion as it becomes several seconds of writeback on spinning disks. A more sane value in this case is 3 (3% of 16 GB is approximately 491 MB).
  • Similarly, setting vm.dirty_background_ratio to 5 may be just fine for small memory values, but again, consider and adjust accordingly for the amount of RAM on a particular system.

Another parameter is:

  • vm.vfs_cache_pressure = 60

The value controls the tendency of the kernel to reclaim the memory which is used for caching of directory and inode objects (VFS cache). Lowering it from the default value of 100 makes the kernel less inclined to reclaim VFS cache (do not set it to 0, this may produce out-of-memory conditions).

What it’s saying in effect is that when caches are written it can result in a long delay while this happens. The kernel will generally do this in background but can also boost priority. Flash drives may be more suitable for large numbers but a modify write is very slow as is a clear.

You can see your current settings via

sysctl -a | grep dirty

I asked if my setting where the default in another thread but no answer. I ran without swap for a while so they may have been changed but they are as per the ones arch say are best to avoid. I have 24gB of ram.

The byte versions of that are zero’d when the % ratio’s are set and the same thing will happen to the ratio’s if bytes are set. The background figures are the point where the kernel starts being more aggressive. It’s of interest to me because my machine does block occasionally. Also there are disk accesses every 5 secs due to writeback checks timing. They hardly ever do anything so probably also relate to low memory systems from years ago.

You can also clear unused write caches via

echo 3 > /proc/sys/vm/drop_caches

echo 1 and 2 clear other things.

At the moment I am not sure what goes on in respect to read caching but there are oddities. For instance if I have firefox using a gig plus this may or may not clear when it’s closed. Also an update increased them markedly and they just stopped there. It’s hard to see why changes in the read cache needs should noticeably slow thing down. Only the need to load from a drive.

In order to see what is going on I’ve found top to be more useful than free. The man pages are pretty long. The main things to read are the meaning of the column headers and that a press of the f key can be used to change the sort order and which columns are displayed. Pressing it brings up a short help message at the top of the view. The cursor keys navigate that. Also that shift w saves the current settings for next time it’s run. . In fact many key presses do something while it’s running so take care, esc or q quit.


Too late to edit, Actually my vm dirty ratio is 20%, background 10.


Having what appears to be the same issue and it seems to be Chrome -related. I’m working on a large Java project, if Chrome is running then Netbeans + Redhat EAP 6.4 (JBoss 7) will fail to start, reporting “not enough memory” - or if already running will report “Not enough memory to fork a new process”. However ‘mem’ and ‘free’ report tons of memory available. Killing Chrome fixes the issue, and running exactly the same tabs etc on Firefox is perfectly fine and does not interfere with any Java project activities (unfortunately the company insists on using Chrome). The same conditions never caused an issue on recent versions of Ubuntu and never had anything like this on OS X / MacOS. Any ideas? I’m pretty close to giving up and going back to Ubuntu…
Hardware: A fairly new System76 Leopard Extreme with 32 GB of memory, running OpenSuse Leap 42.2.