Leap 42.1 - Partitions

Hi all,

I’ve built a new system and want to use Leap 42.1. I have 1 SSD @ 250GB and 2-2 TB HDDs (and 32 GB DRAM). I used imagewriter on my openSUSE 13.2 system and “burned” a USB stick with the image. I wanted to do this for partitions:
[li]On the SSD[/li][LIST]
[li]157 MB - /boot/efi - FAT[/li][li]32 GB - swap - swap[/li][li]~210 GB - / - BtrFS[/li][/ul]

[li]On the 2 TB HDDs[/li][ul]
[li]Create two mirrors using the Expert Partitioner[/li][li]1 mirror 930 GB - /home - ext4[/li][li]1 mirror 935 GB - /data - ext4[/li][/ul]

I get past through the installer without error. It starts installing, get’s to around 7%, and then reboots. I’ve removed the USB stick and nothing is there. I keep the stick in and we go through the installer again. I’ve never worked with SSDs before. Is it my partition scheme, or is it something else I’m doing wrong?


How did you create the stick?
Did you verify the downloaded iso?
Are you actually using UEFI?

Also be certain the install is going to the correct drives and not to the USB stick

I’m also curious for the partitioning, is it MBR ( not working with UEFI/Secure boot ) or GPT ?

Getting ready to pull what remains of my hair out. I burned Leap 42.1 to a DVD. I have an Asus Z97-E motherboard. I’ve searched numerous places and it’s supposed to accept Linux without issue. It runs a “UEFI BIOS utility” for setup. The only UEFI mode for install seems to be Windows (that sucks!). So I set the OS type to “Other OS”. The Boot\CSM launch setting is set to Auto. So, with all that said, I don’t believe a /boot/efi partition is necessary.

But, I boot from the DVD (I’ve verified the media is fine). I get the GUI for install, and go through the setup. The farthest I got is to about 36% and no joy…it locked up and rebooted. Just for a test, I tried an altogether different distro to see if maybe it’s Leap that was having the problems. Nope…same thing. I’m very frustrated and I’m not sure at all where to turn. Perhaps it’s the SSD that’s the problem and I just need to go back to a plain old HDD.

Any help is most welcome and very appreciated!!


One boot the install media as EFI You want to boot to EFI mode to install in EFI mode
two select Windows mode see how that goes. Never seen this option before so not sure what it does maybe dig in the MB docs,.

OK. I changed the MB Boot\Secure Boot OS Type to Windows UEFI mode. Keeping the Boot\CSM to Auto allowed the Install GUI to load! But, it seems like I have a very limited time until the installation freezes on me. That happens constantly. This is no longer a partition issue, but something else. Why does the install keep freezing on me? What can I look at? Is it hardware? I’m at my wits end! Please help!


I know this is not what others would recommend. But when there is no windows installed, I still choose to disable the UEFI and prefer legacy mode and yes too I even use MBR not GPT.

And I still default to ext4 for / and /home

Well such has worked for me for years and years, been rock solid, no data loss ever. No installation issues…

OK…I tried this. I removed the SSD and am just using the 2- 2TB HDDs. The install was purring away, but got this:

Internal error. Please report a bug report with logs.
Details: undefined method ‘concat’ for nil:NilClass
Caller: /mounts/mp_0001/usr/share/YaST2/modules/BootStorage.rb:181:in ‘block in InitDiskInfo’

I clicked OK, and it’s continuing. Any thoughts?

After I posted this…it just froze again. Sigh. Got to 47% this time. I may try the ext4 for all in the next go around.


No idea

But I suggest ext4 and forget any idea of RAID if you were doing that

I create the partitions before hand but you can do it in Yast partitioner, it’s just not as easy for some to see how.

The route you have to choose is ‘Create Partition Setup’ then ‘Custom Partitioning’ for experts
From there you can set the mount points for / and /home (just expand the tree on the left to the partitions on the HDD or SSD

Is this a skylake processor??

It’s a Haswell processor. I’m going to call NewEgg shortly. Maybe it’s a “DOA” processor.

Just an FYI…motherboard and processor being RMA’d. Sigh.

Sorry to everyone for the panic. I was excited and went overboard.

I do have a question, though. If I have 32 GB of RAM, do I need a swap partition? And should it be on the SSD or should it be on one of the HDDs?

Thanks again,

You probably don’t need it
And I’d suggest it goes on the HDD not the SSD
If it’s on a SSD that’s for normal desktop use, I see some suggestions that you change swappiness from 60 to 1 (this is I think to help reduce wear)
If you put swap on the HDD, this may not be a concern, I think.