Leap 42.1 KDE very slow working speed

I’m using openSUSE 13.2 for a long time, and now I decided to give the last version a try. I installed it on my laptop alongside with 13.2.
However this doesn’t seem as an improvement.

openSUSE 13.2 + KDE4 runs pretty effectively on my Packard Bell dot s, there are rare small glitches but they do not bother me.
Leap 42.1 + KDE5, which is installed “from the box” doesn’t run at all b’cause it crawls. Uhm, I mean it crawls too slow even for a lizard.
Does it mean that KDE5+Plasma and all that stuff are too fat to run on not quite bad dot s? Is there any sense in tuning that 42.1 or not?

I’m guessing that is a video card issue.

I ran into what you describe, on a system with Nvidia graphics. Disabling desktop effects, or setting them to use XRender (instead of OpenGL) pretty much eliminated those problems.

Okay, my graphics card is integrated. Still, 13.2+KDE4+desktop effects (all kinds of eye-candy like wobbly windows etc.) run good. I do not know about OpenGL in that system, I’ll try switching it in the new one, but it’s quite difficult to perform, I must wait for minutes after I ran something. Even popup hints are showed after a very long delay, and in some cases they are empty white boxes.

Login to “Icewm”, which should run okay.

Edit the file “.config/kwinrc” (relative to your home directory).

Look for the line “OpenGLIsUnsafe=false” in the “[Compositing]” section.

Change that “false” to “true”.

Note that this is easily reversed at a later time.

Then login to KDE. If it now runs well (but probably without desktop effects), then you had a video problem.

I toggled Compositing from OpenGL2.0 to XRender and the system is running better, but yet I know that under openSUSE 13.2 my Compositor uses OpenGL2.0 and runs fast. So what is difference between OpenGL2.0 under 13.2 and OpenGL2.0 under 42.1 then?..

From what I can see the new KDE5 which is used in 42.1 (using XRender) is too weak yet. 13.2+KDE4 using OpenGL is still much better. For example, when I press the Main menu button, there appears a container for it, just a half-transparent box over the desktop, after 5-7ms it is filled at last with menu entries. This looks glitchy.
The search-and-launch widget is no more. Like it was, I mean.

I fixed by removing the following file (outside of KDE). Now the menu loads instantly


Hope it helps