Leap 42.1 KDE kwin not remembering opened window positions

Hi all,

First, decided to try OpenSuse after some years away with the Leap 42.1 announcement. Downloaded it yesterday, install went without a hitch (stuck to Ext4 only, though, as it was installed to a partition of a drive sharing many other Linux distros). Leap 42.1 seems, quite to my surprise, really nice so far. And good heavens, Yast is absolutely wonderful-----why can’t Yast take over the ubuntu/debian worlds. It is so much more easier and intuitive.

Ok, here’s the only problem I can find so far with Leap 42.1 KDE version: no matter what you do, some programs/functions (like dolphin, like konsole, etc, etc) WILL NOT remember their opened location setting despite me setting them every time:

–right click the window’s tab bar
–up pops the little menu with the "More Actions’ choice
–click this “More Actions”
–then choose “Special Window Settings”
–and from there place a “check” in both POSITION and SIZE, with ‘remember’ picked for each.

No matter how many times and/or how often I set this, or clear it, or reset it (even going into Desktop Settings to set it), KDE kwin just ignores and dictates to you where it will always open that window. One of the joys of using KDE, especially with two or monitors, is having this what I consider “very important” function work. It goes a long, long way towards user happiness.

Can anyone help with this? I walked upstairs to another of my machines, that also has two screens, install again went great, but I’ll be dam#ed if KDE kwin does the exact same thing. So this problem is reproducable. Is it this a bug and/or problem with Leap 42.1’s implementation of KDE?? If so, is it fixable? If not, I am already tired of dragging my multiple windows open around where I want them, which forces me to regrettably walk away from Opensuse once again.

Thank you for any help.

P.S. Please know I am a heavy user of KDE desktops on quite a few other Linux OSes out there (MX-15, Kubuntu, Linux Mint, Ubuntu, even the Puppy Linuxes & Porteus I use)…so it is not like I don’t know my way around KDE after 7-8 years. Is there some “override” setting put in Leap 42.1’s implementation of kwin that is causing problems??

Is it fully up to date? Which version of KDE? The shipped KDE had issues

Hi gogalthorp,

I ran YAST after I install it, asked it to look for updates, but it said there was none. Gawd almighty, will someone please fire a brick between my eyes?:X When I have ever encountered a Linux installation that didn’t do updates after installing it. That’s gotta be it…I just don’t know my way around Yast well enough to that the updates will come that way…and the doggone taskbar icon keeps saying my system is fully-up-to-date. Hmmmm, I need to learn Yast more, as I must have did something wrong setting it up.

In the meantime, can I ask, gogalthrop, can I just run update from the terminal? Should it only be something like:

sudo zypper update

Or is there more I should write along with it. What’s weird is that in Yast last night, I used the GUI to add “Packman”, I also had Yast update itself, which it did, but it showed no updates (despite nearly all the repositories being checked (except for the debug ones).

Sure use zypper up. The updater on the tool bar should have notifies you. BTW are you sharing your home between Linux’s

No, no sharing of /home. They–the partitions-- all (/home and otherwise) are locked into their own island, haha… I even let OpenSuse take over GRUB, as it nicely saw all the other Linux OS partitions, accounted for them, and put them in GRUB for me to pick when starting up.

Dang it, the terminal command “zypper up” shows "The Following 45 package updates will NOT be installed—starting with amarok amarok-lang fdupes"……and ending with "…ibswscale3 jpegtools sox. Then it stops by saying:

“Nothing to Do”

…and drops back to the cammand terminal line #

Ugh, what I have got configured wrong…shouldn’t those updates be installing??

These are the software repositories that are enabled in YaST2:

–Main Respoitory (NON-OSS)
–Packman Respository
–Update Repository (Non-Oss)
–Main Update Repository


Everything in YaST2 is configured correctly, as far as I can tell. It shows no updates are available (checking all the respositories as mentioned in the previous message). Even the taskbar, when clicking on “updates”, says the system is up-to-date.

So, KDE under Leap 42.1 is still is NOT correctly handling the remembering of opened window location (despite the user explicitly setting it) for programs. Here is a stated bug thread link from kde itself, dated 15 Oct 2015, saying this is now a known bug in the Ubuntu-side of things from 15.0 up through 16.0.


It says this bug is “fixed”, but only if the OS team of compilers sets up their KDE correctly when putting the OS together. I just installed Leap 42.1 to another machine, and after two different installs now, to two different machines, that this is not a fault on my end. These are brand, new fresh installs, one to a multi-partitioned hard disk, the other to its own brand spanking new SSD drive. Still, Leap 42.1 KDE kwin will not remember opened app/program windows position and size.

Thus, in summary, Leap 42.1 KDE is just screwing up with regards to this very important function (for people who have 2 or more monitors------one of the very attractions of KDE is having complete control over where are programs/apps windows are opened & in what size and location. Somehow, this just doesn’t seem to work in OpenSUSE Leap 42.1…darn, I really wanted to come back & stay with opensuse, but this is a deal-killer.

Oh well, Hope you guys get it solved in the future. Other KDE implementers out there that I’ve used before and still recently use (Arch, Manjaro, MX-15, Mint, Ubuntu, Kubuntu. etc) haven’t faced this problem from one of problem. Leap 42.1 team, this needs to be looked at more in-depth because I don’t know anyone who doesn’t use at least two monitors nowadays on one of their systems. And using two monitors requires the fine, granular control of window size and placement remembered, which means a perfectly functioning KDE kwin.

P.S. thanks for trying to help gogalthorp!!

How did you install if not from a ISO then you would automatic be up-to-date. Check which version of KDE. Look in Yast Software management

You do understand that this is a user supported help forum?? No developers here you must report on bugzilla if you want something fixed.

IMO KDE5 has too many regressions still on 13.2 but it has been improving and I suspect it is fixed in 5.6 or 5.7