Leap 42.1 - File corruption / missing data on FAT32 partition

I have a computer on which I dual boot OpenSUSE Leap 42.1 and Windows 8.1. I have a FAT32 partition on the hard drive so I can share files between Linux and Windows. Lately I’ve noticed some file corruption or missing data on the FAT32 partition. I usually notice the problem if I save a file to the FAT32 partition while running OpenSUSE. I haven’t noticed problems when saving files while running Windows, but I am in OpenSUSE a lot more than Windows on this computer. The problems I’ve noticed are:

  1. Save a file from OpenSUSE. Boot into Windows. The file is nowhere to be found. Boot into OpenSUSE. I can view and open the file.
  2. Save a file from OpenSUSE. Boot into Windows. The file is corrupt. Boot into OpenSUSE. The file is still corrupt.
  3. Save a file from OpenSUSE. Boot into Windows. The file is nowhere to be found. Boot into OpenSUSE. The file is nowhere to be found. If I run fsck or chkdsk, no errors are found on the disk.

There are a few .CHK files on the FAT32 partition, but I’ve been unable to recover anything from them.

Is there anything I can check on my Linux system to prevent data corruption on the FAT32 partition? Are there any known issues when writing to FAT32 on Leap 42.1? Or, does this look more like a sign of a failing hard drive?

I converted my FAT32 partition to NTFS several years ago.

However, even when it as FAT32, I never ran into the problem you are describing.

I do see that happen if I plug in a USB drive, and write to it. And then I unplug the USB drive without first unmounting it.

How are you shutting down your linux system? You should be using the “shutdown” command or equivalent, or you should shutdown from the desktop exit options (depends on desktop). If you are just turning off the power switch, without going through normal shutdown procedures, then you can expect data corruption.

I’ve been shutting down using the desktop options in KDE.

Have you considered the possibility that you have a failing disk?

Check that Windows Fast Boot is disabled or make sure to actually shutdown it, bypassing Fast Boot.

Fast Boot was enabled, so I disabled it. I’ll see if that helps. Thank you.

be sure to disable fast boot from inside windows (present on win 10) besides the option given in bios.

be careful with fast boot it’s a form of hibernation
once upon a time running XP I managed to destroy the data of a whole partition tanks to “hibernation”
when hibernating windows loads an old partition table and new data is not in it’s records so it can cause confusion
fast boot is not as bad as full hibernation unfortunately with the latest Creators Update you can’t turn off fast boot so I’d avoid sharing partitions between Linux and 10
if you use ext4 there are ways to access your home partition in read only mode from windows and Linux can read off of ntfs partitions if you really need to share data use an external disk or usb

if somebody knows a way to shut off fast boot in Creators Update please share it, as I did turn it off in the previous 10 anniversary update but that option is nowhere to be found in the latest build