LEAP 42.1 Chromium won't remember login info

Hi all,

Just upgraded to LEAP 42.1 (fresh install) from 13.1. One major annoyance I’m having right now is that Chromium doesn’t remember my Google login info, so every time I restart my laptop I have to re-login (which is painful because I get a text message to my phone for logging in to Google). Any ideas how to fix this?

what desktop do you use as I do believe Chromium uses kwallet for password storage so if you didn’t enable kwallet integration (or if you don’t have a kwallet password) Chromium will not store your password,
about text messages, I don’t use Chromium but I do login to google now and then and I’ve newer gotten a message (email right) about login in from a pc browser, I get emails when I change something on my phone (I play with roms) and I have to re-enable my google account

I think I get it, your issue is that logons are not remembered across app restarts, check your cookie settings, if your cookies are set as a session cookies you will need to relogin, set your cookie policy to something else, this is a security feature, Firefox has an Exceptions list for sites who’s cookies you’d like to keep so does Chromium see the part about exceptions here

I’m using XFCE desktop, it shouldn’t require kwallet of gwallet (or whatever gnome keyring dameon is called).

I currently only have chromium installed, chromium-desktop-gnome and chromium-desktop-kde are not installed as I’m not using KDE or GNOME.

as I wrote in my second post it’s your cookie policy change it or add google.com (youtube.com as well as other google uri’s) to your exeptions list
in my first post I thought opensuse didn’t remember your passwords chromium uses kwalet under plasma 5 to store passwords the need to re-authenticate is a cookie issue and probobly one you configured with google see your google profile page

This is NOT a cookie issue, I need to sign in to the browser, in addition to every single frigging web page. I’m asking why I need to sign in to the browser every time I restart

In Chrome’s settings - Advanced options - Passwords - Manage passwords - Check the option “Login automatically”.

That’s already enabled, I still need to login to Chromium every time I restart.

To test if this is a chromium bug ( I too think there’s a cookie issue ), close chromium,

Open a terminal window, and do:

mv ~/.config/chromium ~/.config/chromium.orig

then restart chromium and see if the problem persists.

OK, I’m in the middle of something right now but I’ll try that before restarting my laptop and let you know how it went.

Check this:


Thanks, that seems like the problem I’m having. I’ll be following that thread.

OK, I’m still having this problem. I guess I have to wait until that patch appears in LEAP repos, right?

Relevant: https://forum.manjaro.org/t/chromium-forgets-cookies-at-reboot/10813

If anyone else is having this same problem, there’s new patch (arrived this week I think) in the LEAP 42.1 repos that fixes this problem, so just do zypper up.