Leap 42.1, Athlon 5350, and LG L246WP display problem

I just updated from openSuSE 13.1 to Leap 42.1. I’m running an Athlon 5350 and my monitor is a LG L246WP monitor which has a 1920 x 1200 native resolution. It is connected using HDMI. http://www.lg.com/us/support-product/lg-L246WP Over the years, I have had the problem that I am about to describe on Windows with both nVidia and AMD graphics cards.

The problem is that the proper native resolution is detected, i.e., Leap 42.1 detects that the monitor’s native resolution is 1920 x 1200, however, the actual video area on the monitor is skewed up about up about 4cm and to the left about 5 cm so that there are black bars at the bottom and right of the monitor that are unusable. To try to make this clearer, imagine the entire desktop skewed up on your monitor by about 4 cm and left by about 5 cm such that these portions of the desktop are not visible. I have tried switching to lower resolutions, but all of them display a similar result.

As far as I can tell, there is no way to move the desktop back to its proper position.

I have settled on 1280 x 1024 as the most usable resolution because the display is properly positioned on the monitor from top to bottom, but it is still skewed about 5 cm to the left. I have also moved the task bar to the right edge of the screen so that I can get at the “programs” icon.

This same thing happened to me on 13.1 when I tried to use the AMD driver. However, the default 13.1 driver properly positioned the desktop on the monitor.

When I had the problem on Windows with AMD and nVidia, I contacted their technical support, and they subsequently fixed the problem in the driver.

Anyone have any ideas as to how to get the display in the proper position on the monitor?

Thanks.

Well you can always adjust things using the monitor’s control

Thanks for your reply, however, when the monitor operates from the HDMI input, all positioning of the display within the monitor’s settings menu is locked out with no way to enable them; therefore, I am unable to accommodate this problem with the monitor’s control. That is why AMD and nVidia both had to change the drivers to correct the problem.

Use the vga input then

Under the video menu of your tv, is there an option for custom?
Play with the settings of your tv, there should be a selection there that will allow you to set the tv resolution and image positions.

It could be faulty EDID info - EDID is the table of display characteristics in the monitor firmware that the video card reads on boot, to set resolution/freqs/etc.

I’ve seen this with (1) defective EDID tables, usually on a TV used as monitor, (2) not fully wired VGA cables, which seem to lack the pins used to probe for EDID and (3) wrong vertical/horizontal sync frequencies.

I’d try a different HDMI cable just for the sake of completeness, as these cables, unlike VGA, should always have all wires - but one may be defective.

Then I’d try checking frequency settings against the monitor manual, and also (improbable) if there’s an older xorg.conf that may be interfering.

Just guessing, thou.

A quick search of ‘LG L246WP EDID’ shows that the problem with this model is well known, with a number of hits describing the issue and possible fixes.

If you’re feeling brave, you might try following the steps outlined in this video to correct the monitor’s edid. Even though it mentions Ubuntu, the tools are available for openSUSE (and other distros).

http://www.allreadable.com/170fGx9g

You’ll need to download and install i2c-tools first.

  1. If you’re using the proprietary NVIDIA driver, it is possible to use a custom EDID file, by first reading the monitor’s EDID, and then editing it, applying the required corrections, and then saving the corrected data to file.

<:)Thank you. It has been a while since I searched on this problem, and at that time, I found nothing like this, so thank you for your help on this. I am going to give this a try. This looks like I might just say goodbye to this problem with this monitor. It still has a lot of life left in it. At this point, I am using the graphics on the 5350 (its an APU) so the nVidia solution is not presently an option for me. Even so, changing the EDID data in the monitor seems the better route as it is a permanent solution to the problem no matter what computer the monitor is connected to. I am on old hardware guy, but before I try it, I will see if I can read the proper locations from the monitor before I change the EDID data.

I had contacted LG about this in the past, and the best they could offer was to send me a monitor of their choice and keep mine - needless to say, I did not want to get rid of it.

Anyway, I’ll let you know how it turns out.

:shake:<:)Awesome! It was even easier than in the video. I installed i2c-tools using the software manager, did the modprobe as in the video, tested to see if I could see my monitor’s edid data - I could - it was device 0, put the monitor into service mode -> aging mode, then changed the same bytes as in the video and 1920 x 1200 perfectly in leap42.1. It took maybe 10-minutes since I was being careful. The best part about it is that this sounds like it will be a permanent fix. No more headaches when changing video cards or OS.

I owe you a beer or something, but since that is unlikely I gladly added to your reputation!

Thank you greatly!!

Glad to be of help with pointing you in the right direction, and well done with pursuing the permanent fix! :slight_smile:

Just a thought: AFAIU disabling EDID extensions as shown in the links above will turn off hdmi audio and other capabilities, so it should be used only on monitors, not on digital TVs connected to the PC by HDMI cables, right?

If so, then you’d have no audio if later connecting a set top box or similar through HDMI, for example.