Leap 42.1 Apache2 VHost configuration SSL support disabled

I had my site working fine under openSUSE 13.1 with four VHosts, for both http: and https:.

Then I upgraded.

Leap now smushes all my vhost.conf and vhost-ssl.conf files into single files. I can still access the sites with IP-based vhosts by http, but named hosts don’t work and SSL doesn’t work at all.

Hours, days of googling no joy.

So I nuked all the vhosts in yast and try reinstalling them. Go through the dialog, get to page 2: SSL Support is there but disabled.

Any ideas? If this is the wrong forum please say, I couldn’t find any other more appropriate.

Cheers, Andy

Sounds like you’re not creating and managing your vhosts using YAST.

Install the YAST applet for managing Apache websites with the following zypper command

zypper in yast2-http


OK, I have reinstituted the site with ten vhosts (vhostn, www.vhostn, n=1…5) on both http and https. They all work just fine, e.g.,

But if I invoke **yast **it combines all the vhost.conf files into a single ip-based_vhosts.conf file and deletes all the vhostn-ssl.conf files (yikes!!), disabling SSL. And it won’t let me change to namebased vhosts. And no manner of googling reveals documentation on how to avoid these effects.

Basically, yast http-server is broken and has put itself out of business.

Bottom line: do the .conf files manually in /etc/apache2/vhosts.d and do not touch yast http-server.

I have saved the working site as another directory so that if something else mucks it up I can just recopy and restart the server.

But this is NOT satisfactory. I’ll file a bug report.

Cheers, Andy

??? I’m using the yast http-server module??? is this yet another different module??? Can’t check it out right now, the server provider is doing maintenance on the server farm.

Zypper returns:**

tm2t:~ #** zypper in yast2-http
Loading repository data…
Reading installed packages…
Package ‘yast2-http’ not found.
Resolving package dependencies…

Nothing to do.
tm2t:~ #

There is no http applet. There is the http-server applet, which I am using, which renders the results previously described.

It is broken, it destroys my /etc/apache2/vhosts.d/ files.

So, of course, I am not using it.

I tried, it failed.

Kind regards, Andy

I’ve never been able to use YaST to get a site to be configured properly. I think I first tried around 2011 or maybe 2012. I normally install Apache 2 and enable mod_ssl with YaST and then leave it at that. Normally I just do what you did, Alavarre, and manually tweak the apache conf files and hope that I never have to enter the http config module again (which will obliterate the manual config) or that a patch doesn’t just obliterate the manual config. I’ve only had my config obiterated about twice over the years and I learned my lesson to back it up after the first time.

I always used to configure and compile from source (so obviously I had to configure Apache manually), but I decided to switch to just managing the servers through YaST to make it easier to panage patch application. Maybe it’s because I started out manually configuring Apache that causes me to find it so hard to use YaST to configure Apache? I dunno. It’s the thing I dread the most when trying to get set up after installing a new version of OpenSuse though. The only thing that stops me from just giving up and going back to source compilation is the thought of having to faff about with manually patching Apache.

Sorry, I mis-posted the yast2-http-server applet.


Stephen hello. Thank you for the confirmation and to TSU for his clarification.

Not a problem that yast doesn’t work, the only problem is if you don’t know that it doesn’t work… :frowning:

We’re pretty much good to go now with a full backup using individual conf and ssl.conf files.

I did find a brand-new documentation for Leap 42.1:
April 21, 2016

but it has no reference in it to this problem, indeed no mention whatsoever of **ip-based_vhosts.conf

**I too hate faffing about… :slight_smile:

I guess this issue is closed.

Cheers, Andy