Leap 42.1 64-bit , no sound, no video, & codec-problems with VLC

I have just installed Leap 42.1 64-bit.

The major problem: I got no sound at all.
I have tried Dragon, Amarok & VLC, but no sound.
And when i try to view a video (mp4) Dragon starts but shows no video.

I have installed VLC 2.2.1, and tried it instead of Dragon,
but VLC gives an errormessage about codec-problems, both for mp4 and avi, so i can´t use VLC for testing.

Volume-settings are 100 %
Sound-card is configured as “Primary” card (card 0)
And i have updated all installed packages.

It´s not a hardware-problem (computer), as both audio and video works OK on Windows 7,
and Dragon also worked on Debian 8.3 yesterday, both sound & video…

Any ideas ?

do you have the packman repo?
post your repo list

zypper lr -f

if not do this (you can copy/paste in a terminal)

sudo zypper ar -f ftp://packman.inode.at/suse/openSUSE_Leap_42.1/ packman
sudo zypper dup --from packman

I have no idea what that is…:wink:
But i will take a look next time i use Leap.
I´m using W7 now so i can´t check right now.

Anyway, i will try the code above in a terminal.

Problem solved.
I also got a lot of other errormessages from the O/S, fx. when updating, so i installed Linux Mint instead…
No sound & video-problems, everything works as it should.
Leap is buggy, feels like a “beta”…:frowning:

no it’s fully open and comes with no patented stuff, Mint bundles patent codecs and is 3rd level fork of debian with limited support and heavily depended on ubuntu or debian not to mention the hack they had a few weeks ago.

adding an extra repo is not that hard, but hay it’s your choice.