LEAP 15 Wine does not start

Hello,

I’ve installed all versions of Wine available in the repositories for leap 15 (and some). 3.17, 3.17 staging and 3.18. They all give the same error :


radu@linux-2141:~> wine notepad.exe
No protocol specified
No protocol specified
0009:err:winediag:nodrv_CreateWindow Application tried to create a window, but no driver could be loaded.
0009:err:winediag:nodrv_CreateWindow Make sure that your X server is running and that $DISPLAY is set correctly.

Some more information


radu@linux-2141:~> echo $DISPLAY
:0
radu@linux-2141:~> xhost +       
No protocol specified
No protocol specified
xhost:  unable to open display ":0"

Everything else works, i have an X Server running and all the games from Steam run without any problems.


adu@linux-2141:~> nvidia-smi
Mon May 21 17:29:06 2018        
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 390.59                 Driver Version: 390.59                    |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX 1070    Off  | 00000000:03:00.0  On |                  N/A |
| 28%   33C    P8    12W / 151W |    479MiB /  8116MiB |      3%      Default |
+-------------------------------+----------------------+----------------------+

Anyone have any idea why wine is not working ?

Thx,
Radu

Never-mind, i just rebooted the system and it works. **** this starts to look like windows :\

Well, Wine isn’t Windows, but apparently it is near enough to have some of it’s qualities. rotfl!