LEAP 15: Offline Upgrade USB loads but hangs on loading udev

Fellow opensuse users,

I have been using Opensuse since 2008 (13.1). I am trying to do an offline upgrade from 42.3 to 15.

A bootable USB is being created using the SUSE Studio Imagewriter with the Leap 15 iso downloaded via torrent.

The stick loads but on selecting Upgrade or Check Installation Media, the installer hangs on loading udev.

What can I do so the installer finishes loading? I tried playing around with the non-UEFI/UEFI settings and the kernal setting set to safe but still no go.

Any suggestions? :expressionless:

Media check does not work for USB sticks only on CD/DVDs. If you have a good checksum checked iso image a copy to a USB should be good.

Also not sure how up to date Imagewriter is. If copying from Linux just use cp or dd command for cp cp *pathtoimage */dev/sdX were X is the reference to the device Note copy to device NOT a partition on the device. You can find USB deice by fdisk -l . If in Windows use a good binary copy program like https://www.osforensics.com/tools/write-usb-images.html

I did my installs as clean installs.

I did try an upgrade – twice – in a virtual machine. The upgrade worked. However, it first connected to online repos. It did not give me a choice for doing it offline. I suppose I could have removed the network card from the virtual hardware, to see what happens. But I didn’t try that.

I am guessing you are installing UEFI.

Highlight the Install option on the menu, type “e”.

Scroll down to the line that starts with “linux” (linux-efi?).

Hit the END key to get to the end of that boot command line, it wraps.

Add a space, then add “self_update” (without the quotes), then press F10 to boot the installer.

You will need to wait a few moments as it downloads some additional files.

See if that solves your problem.

If not installing UEFI, then just add that to the end of the command line parameters.

I have the exact same problem on 2 different machines, luckily I still had a 42.3 ISO so I’ve used that for the time being. Bit odd, though. I may wait another few months until I go to 15.

I tried that but udev still hangs.

SUSE Studio Imagewriter (from the repos) creates on my usb the following:

  1. 1.3 mb free space
  2. 4.0 mb /dev/sdb1 – EFI
  3. 3.9 gb /dev/sdb2 – ISO/bootable.

My bios detects the usb as either UEFI/regular. I tried both settings but the usb still hangs on loading udev.

I tried some research into udev but why would the installer be hanging there? Is it the USB/BIOS or my hardware?

Any suggestions would be helpful. I don’t want to do a live upgrade, but might consider it.


I used the usb on a different and older but more powerful laptop and the usb loaded through the Check Installation Media option.

So…what option(s) in BIOS would cause udev in the installer to hang? I will try turning on/off some options there and report back.

Hi, I am trying to install via a DVD. The install hangs, last message was something to the effect ‘udev=OK’.
Then the triple green bar at the bottom of the screen appears, grows, stops growing. The CD-drive stops,
and that is the end of the exercise. The CD has been checked and found to be OK.

The PC is an ASUS N75SF. No problems booting 42.3.
A memory check has been performed, no memory errors.

Best regards,
Jan Christian

For USB install be sure that UEFI option iommu is turn on. or USB may stop working as soon as kernel is loaded.

Had this not on an install but a replacement of mother board recently the default on the MB was iommu off and USB devices stopped working as soon a kernel loaded

Yes, unfortunately. I have learned since that the “self_update” feature is not enabled in openSUSE, though it is there for SLES, etc.

I am quite disappointed in that.

… although, I was sure it worked for me in a couple of instances, so I am still left scratching my head.

Okay, fellow opensusers:

I fixed the issue and got the installer to load. It seems to be hardware conflicting settings in bios that is the problem.

I turned on all Energy Savings/Internal Pointer/Lid close settings and turned off all unnecessary hardware (eth/wireless/camera/bluetooth).

Then I ran into another issue I ran into trying to load a Tumbleweed usb:

Calling the YaST module 'inst_update_partition has failed.
More information can be found near the end of the '/var/log/YaST2/y2log' file.

This is worth reporting a bug at http://bugzilla.suse.com/.
Please, attach also all YaST logs stored in the '/var/log/YaST2/' directory.
See http://en.opensuse.org/Bugs/YaST for more information about YaST logs.

Options: Next | Quit | Back | Retry

The installation fails after giving password to encrypted home!


You have not given enough detail. However, it is very likely that you have bumped into
Bug 1097811, which is derived from Bug 1097811

The first of those bug reports is more concise, and indicates what you need to do to work around the problem.

You possibly have an entry in “/etc/fstab” to mount “/dev/mapper/cr_home” as “/home”. However, it might use a string other than “cr_home”. I’ll assume that it is “cr_home” for this reply.

You need to find the UUID of that file system. You can do that with the command

blkid /dev/mapper/cr_home

And then you need to edit “/etc/fstab” and replace
except that you must use the actual UUID string that you found in the first step in place of that “1234-5679-whatever” that I used.

Note that the quotes I used above are for clarity and are not part of what you actually edit.

Once you have done that, your system should still boot to 42.3 as before. That’s a good test that you got the editing correct. But now, the update should work without running into that problem.

This all assumes that my guess is correct on the problem that you are having.

If you are using other encrypted partitions (such as encrypted swap), you might want to make a similar change to those (i.e. use UUID in “/etc/fstab”).

This is the case technically in /etc/fstab.

However, in the YaST Partitioner tool in the settings pane, the default mount by option is UUID.

I will think about whether I want to attempt to possibly break my system to upgrade it rather than just buy a new hd and install from scratch.

Thanks for the input.


Ok, there is a work-around to the installation bug:

Calling the YaST module 'inst_update_partition has failed.
More information can be found near the end of the '/var/log/YaST2/y2log' file.

This is worth reporting a bug at http://bugzilla.suse.com/.
Please, attach also all YaST logs stored in the '/var/log/YaST2/' directory.
See http://en.opensuse.org/Bugs/YaST for more information about YaST logs.

Options: Next | Quit | Back | Retry

Encrypted partitions must be mounted via their uuid instead of paths in /etc/fstab. This allows the installer to load the encrypted partitions and the installation/upgrade to proceed.

Can anyone help me on this problem? I’ve tried looking into the bios and have tried a few changes but no such luck. The laptop is an old Asus mx553.

Leap 42.3 works absolutely fine but 15 won’t.

mx553? Are you sure you did not mean:x553ma?

I can only offer my personal experience:

It seems to be a hardware issue. The kernel cannot detect or use a driver for one of the devices. I turned off ethernet/bluetooth/audio/cmos camera in bios. These can be turned back on later.

  1. See if an update for bios exists: Version 214 re: asus.com/Laptops/X553MA/HelpDesk_BIOS/

Consider updating bios --may-- be a solution.

  1. Unplug all hw from the laptop.

  2. In bios turn off all unnecessary hardware.

  3. Turn on all settings regarding power in bios.

  4. If the usb stick shows up in bios try booting it with UEFI/non-UEFI.

If opensuse 15 does not like your hardware, which it doesn’t like mine, I have an Asus laptop too, I would think about holding off on upgrading. The hardware issue has given me pause.

I am considering buying a new hard-drive and installing 15 fresh rather than possibly messing up a working system with 42.3.


Thanks for your reply, I will have a look at updating the BIOS. A bit irritating that 15 doesn’t recognise my hardware, yet the older 42.3 does.Seems a bit of a backwards step. It also doesn’t like my Alienware 15 R2, either! Annoyingly with the Alienware, it doesn’t even recognise either of my hard drives!!

Eh, did you perform an md5sum check of the download and compare that to the one provided on the site?

Yup, it was all good. The SUSE install 42.3 works on all of my machines except it doesn’t recognise the HDDs on my Alienware machine. 15 doesn’t work on either of my laptops but haven’t tried the desktop (don’t really need to to be honest as it’s rarely used).

This is somewhat of a “long” explanation, but my intention is to try to get eventually to the cause of this problem:
[Problem is that LEAP 15 install “hangs” are udev “OK”, but the “three green bars” never complete] [Occurs on DVD, Net isos]

  1. I have been attempting to install Leap 15 on my ASUS N76VZ laptop since May 26th 2018
  2. Tumbleweed + Leap 42.1 + 42.2 + 42.3 + opensuse 13.2 have all successfully installed on this machine with the current hardware
  3. Current installed OP/SYS are Tumbleweed, Leap 42.3 and 4 other linux distros.
  4. Tumbleweed live starts and works… LEAP 15 KDE Live hangs on plymouth splash screen
  5. LEAP 15 KDE live failsafe WORKS.
  6. AT bash shell prompt: systemctl start sddm.service
  7. LEAP 15 KDE live failsafe installer works [installed suucessful, but issues]
    7.1 Partitioner decides to use /dev/mapper “layout” for install