Leap 15 live boot problems

The Leap v. of OpenSuse 15 has 3 live versions available, KDE, Gnome, & XFCE (called rescue). I can successfully boot the XFCE, but neither of the KDE or Gnome because of what I’m guessing is a graphics problem. I have successfully booted each of them once in the default mode, but subsequently and w/ a variety of different boot parameters, I can’t boot either again.

The hardware in question is 8G ram and the vid is Radeon HD 4200 and such as Kub 19.04 loads the radeon driver. When the boot fails it ends at OK ‘started x display manager’ and there are a couple of minor failures before that involving systemd; locale service, postfix mail transport agent, and hostname service. There is also an ‘error error’ about ‘no UMS in radeon module’ which I once tho’t was important but now disregard as not being **useful. **

It is important… :wink: since AFAIK UMS support has be dropped…

Try booting with either;




At the grub screen press e to edit and add at the end of the linux(efi)=… quiet

I can’t actually edit the line w/ ‘e’, because E enters into the boot options editing line. I can not see the existing boot parameters to edit, I can only add content to the boot options editing line. I have used radeon.modeset=1 before, also radeon.modeset=1 w/ vga=ask to get to input 324 for my 1280x1024. And I have also tried nomodeset and in combination w/ such as vga=ask. At your encouragement I attempted again to use radeon.modeset=1 once and radeon.modeset=1 vga=ask and then radeon.modeset=0 and radeon.modeset=0 plus vga=ask. Quiet doesn’t really work in the boot options line but I can escape to see the output. I can also eliminate my apic error w/ the boot options. radeon.modeset=1 dies the same place as always, such as default. When I use radeon.modeset=0 the resolution stays lower longer during the scroll and then I get to a text screen that says localhost login: I have no way to get out of that except to input root which changes the prompt and color to localhost:# but then startx only gives me an output of what it can’t do. I could copy all of that down and paste it in here if it would be useful. I believe that is the same output I got w/ nomodeset.

Just to confirm it’s the Leap 15.0 and not Leap 15.1? I think I have a motherboard around here with a Radeon 4200 gpu…

/usr/bin/startx: line 307: cannot create temp file for here-document: No space left on device
xauth: file /root/.Xauthority does nnot exist
/usr/bin/startx: line 307 etc as above

Fatal server error: ee could not write pid to lock file in /tmp/.tx0-lock
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error

xinit failed. /usr/bin/Xorg is not setuid, maybe that’s the reason?
If so either use a dsplay manager (strongly recommended) or adjust /etc/permissions.local and run “chkstate --system --set” afterwards
xauth: file /root/.Xauthority does not exist

Correct. I recently learned that it is appropriate to say Leap 15.0 as opposed to ‘15’. Tnx for your attention here.

I dl/ed the 3 lives from here https://software.opensuse.org/distributions/leap confirmed the hash for each, wrote them to USB w/ Win Rufus using its dd mode. I tried the KDE first and it booted but was a little balky, and then never booted successfully again w/ multiple variations on attempt strategy. I tried the Gnome next and it booted and was functioning fine, but then the video was lost and I never got it to boot again; likewise many varied attempts. Then I tried the rescue XFCE and it has been able to successfully boot repetitively in the default mode. I also used it to experiment w/ booting live and turning off the radeon to see if I could put the radeon in after it booted to the ati/vesa vid drivers, but I didn’t know how to do that.

OK, just tested here with openSUSE-Leap-15.0-GNOME-Live-x86_64-Snapshot20.230-Media.iso (I’m a Gnome-ite ;).

So all worked fine with Radeon HD 4200 (1002:9710)…

I suspect your image writing method, never used rufus for openSUSE images, always use imagewriter.

Gnome uses wayland, I’m guessing Plasma does the same?

How do you mean lost the video, just went AWOL, or just went into power save mode with the screen?

So tested Rufus 3.5 in dd mode, seems to be working as typing this from the live system.

linux@localhost:~> inxi -Gxx
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RS880 [Radeon HD 4200]
           bus-ID: 01:05.0 chip-ID: 1002:9710
           Display Server: wayland (X.Org 1.19.6 ) driver: radeon
           Resolution: 1360x768@59.45hz
           OpenGL: renderer: AMD RS880 (DRM 2.50.0 / 4.12.14-lp150.12.58-default, LLVM 5.0.1)
           version: 3.3 Mesa 18.0.2 (compat-v: 3.0) Direct Render: Yes

First, thanks for testing on your own hardware. Second, good (and convincing) to see it work on your HD 4200. Third, goodjob on coming up w/ a suggestion - don’t trust the image write. Fourth … I should’ve started a bullet list;

  • thanks for testing
  • helpful info that your HD 4200 worked OK
  • good suggestion - don’t trust the image write
  • success came from a somewhat different quarter, but aided by above

Next bullets:

  • instead of Rufus dd (not its primary mode) I used Win Etcher portable
  • success booted Gnome (+ radeon.modeset=1) live w/ improved scroll info no minor fails
  • all of a sudden (as they say) video died while I was dabbling
  • rebooted Gnome same radeon, w/ worse scroll and failure at the graphics stage
  • I decided I must have a USB problem rather than a Rufus vs Etcher problem
  • used a different USB + Rufus dd to write
  • successful boot w/ radeon.modeset=1
  • installed inxi and some of its recommends and see Wayland gfx & radeon

Thank you for you work and advice. I was doubtful it was a rufus problem; usually when the image is improperly written it doesn’t want to boot at all, in my experience

Me too;

inxi -GSxxc 0
System:    Host: localhost Kernel: 4.12.14-lp150.12.58-default x86_64
           bits: 64 gcc: 7.3.1
           Desktop: Gnome 3.26.2 (Gtk 3.22.30) dm: gdm
           Distro: openSUSE Leap 15.0
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RS880 [Radeon HD 4200]
           bus-ID: 01:05.0 chip-ID: 1002:9710
           Display Server: wayland (X.Org 1.19.6 ) driver: radeon
           Resolution: 1280x1024@59.89hz
           OpenGL: renderer: AMD RS880 (DRM 2.50.0 / 4.12.14-lp150.12.58-default, LLVM 5.0.1)
           version: 3.3 Mesa 18.0.2 (compat-v: 3.0) Direct Render: Yes