Leap 15 - Laptop wifi - Startup.... Wait > Password > Configuring Wireless.... Wait > Repeat

Hi there,

I have a problem with the wifi randomly deciding to not complete configuration after startup.
Instead, it thinks about it for a while, then drops you back to the “Connect” button.
It does successfully connect, and once connected seems to work fine, but no rhyme or reason to its tempermental nature.

Two characteristics:
One, after start up it seems to take much longer than normal to prompt for the KDE password manager (30s rather than 3s).
Once it has accepted the password, it will sit and configure the network for ~45s, before failing, after which you need to “Connect” again.
Sometimes it will connect first time, some times after the second or third “Connect”, sometimes it simply can’t be bothered.

This laptop is a 2012 era Samsung Series 9 ultrabook with an Ivybridge 17W dual-core.
The network is a netgear 2800AC fibre modem/router in use since mid-2017.
The laptop has always connected flawlessly to the network (in current and preveious incarnations), on various Suse Leap versions back to 42.1.
The network has not changed configuration since mid-2017, and all existing wired and wireless devices connect fine (inc the notebook yesterday on 42.3).

Signal strength isn’t perfect from where it is used, but it is definately not marginal - or even low.

Any thoughts?

As an update, restarted the laptop again.

It again took about 30 seconds to prompt for the KDE password manager, but once that was done it connected first time.

As I said, temperamental - it may load first time, third time, or not bother at all.

I’ll make a suggestion. I don’t know if it will help.

Right click on the NetworkManager icon in the tray, and select “edit connection”.

In the connection editor for your WiFi connection, go to the security tab. Look for where you enter the wifi password. There should be an option on where that password is stored. The default is to put it in your “kdewallet”. Change that, to have the password saved unencrypted in a file. Note that the file is not publically readable, so this is not as scary as it might sound.

Once you have done that, the WiFi connection should not need access to your kdewallet. And that might improve things.

If that doesn’t help, you can then try making the connection shared with all users. With that change, it will connect before you login to KDE. Making this change will request the root password.

thank you, wifi seems to have stopped being a problem, but new issue found (battery life):