LEAP 15 installer does not like my hardware

LEAP 15.0

AMD athlon ii x4-640 (quad)
USB 3 plugin card

The hardware a rather old, about 8 years.

When the installer loads, it displays the basic menu: Boot from hard disk, Install, Upgrade, (other). However, the USB ports are not recognized, hence, no keyboard. The timer runs extremely slowly; it takes about a minute to time out to boot to hard disk.

Any suggestions what may be choking the installer?

No built-in USB on the Motherboard?

Reason could be USB3-related, your PC seems to be having tough time reading through that card with the installer.

PS: I have 15.0 now installed on a few 10-yr-old-plus machines, running fine, so 8 years is not too old.

I did not look up specs. Is that cpu 64-bit?

The motherboard has about 8 USBv2 ports. I added a USBv3 card to have the faster thruput and access to more modern hardware.

Is that cpu 64-bit?


Another twist: I tried the install on another system with the same CPU; the motherboard is about 5 years newer although without a USBv3 card. Neither the current OS (42.3) nor the 15 installer will read the distribution disks (local or network install) on that system. No problem reading the disks on the older system.

The newer motherboard has USBv3 ports. I plugged the DVD drive into one of those and the system was happy with it, i.e., it mounted the volume. It booted to the install disk and performed normally. It is installing as we speak.

That just leaves the issue of what is different about the older system…

Keyboards and mice don’t benefit from USB ports faster than v1.1 or v1.2, and certainly can’t do better on v3 than on v2 . Did you try plugging keyboard into any of the onboard ports?

The mouse and keyboard are plugged into a USBv2 hub. Always have been. I did try connecting the keyboard directly to to a USB port on the back panel. No change.

The newer system completed the LEAP 15 installation and is running happily.

I did discover that VirtualBox is not yet LEAP-15-ready. Since I use Vbox for running Windows, I am putting this upgrade on hold until that issue is resolved.

You might also try unplugging and replugging the KB and mouse after the installation GUI appears.

Something else to try: remove the USB PCI card only for the installation.

Does your BIOS have any kind of option about USB legacy or such?

When this happens to me and a replug fails to help, I restart with a PS/2 keyboard connected. :wink:

What do you mean by that? Why wouldn’t it be ready? If you actually met a bug, then report it at bugzilla.opensuse.org , sitting and waiting is not going to get it solved if it is a bug. Did you consider a mistake during setup?

Which “that” do you mean?

Why wouldn’t it be ready? If you actually met a bug, then report it at bugzilla.opensuse.org. Did you consider a mistake during setup?

I have reported the issue to VirtualBox.

Very good. Could you post the link to that bug in this thread so anyone else with that issue can add to it?

URL for the VirtualBox defect report.


Hi, this is a known problem. See this message https://lists.opensuse.org/opensuse-factory/2018-06/msg00022.html for instance.
Using the VBox version in the openSUSE repositories apparently works.