Leap 15 gone from the boot menu!!!

Hi everyone!

I do not know how this happened as I did not really install new OSs or messed with grub.

For no reason, today Leap has disappeared from the boot menu!

I have two harddisks.

The main drive /dev/sda1 has my OpenSuse partition. It is encrypted using luks.

The second drive /dev/sdb is not encrypted and has an old broken Fedora installation that I no longer use and some data.

I tried using rescue disk to boot the system, but it does not even detect the opensuse system (because it is encrypted?)

I also tried mounting it with cryptsetup in rescue console and running grub tools, but they do not even find the opensuse again (through everything is there, I can see it with ls).

Also, looking at grub.cfg in the opensuse partition , I see no opensuse listed.

Please help! This is really killing my productivity.

Do this when booted from the rescue disk:

  • Hit Ctrl-Alt-F2 to go the console
  • Mount the partition that contains your openSUSE install, I’ll call it /dev/sdX# , replace that in the code below
  • Do

mount /dev/sdX# /mnt
mount --bind /dev /mnt/dev
mount --bind /proc /mnt/proc
mount --bind /sys /mnt/sys
chroot /mnt

Now you can run yast’s bootloader module. If all is well it’ll regenerate the grub configs and your Leap should be back in the menu.

First of all, thank you for the response.
However, still no luck.

Yeast seems to run fine, but the menu does not change.

I checked Boot from Master Boot Record
Set active flag in partition table for boot partition
Write generic boot code to MBR

All I see on the menu are options for Fedora.

P.S. since my sda1 is encrypted, prior to following the steps you provided, I had to run

cryptsetup luksOpen /dev/sda1 opensuse

and then

mount /dev/mapper/opensuse /mnt

Any other ideas?

I fiddled around with this all day and no joy.

It seems that nothing even detects (yast in rescue mode, grub-mkconfig, etc) the presence and bootability of OpenSuse, though all detect the old broken Fedora.

Is complete reinstalling the only viable option here?

Please help.

So far you did not provide any factual information that would allow even attempting it. We do not even know whether you are using legacy BIOS or EFI boot, nor whether you are using btrfs (in which case previous instructions to mount root were likely incomplete).

Sorry, I am using EXT4 with legacy boot.

I think I am also starting to see the error of my ways:

My bios had both legacy and EFI enabled. Fedora used EFI and OpenSuse used legacy.

If the rescue ends up being not a viable option, I will disable legacy and install OpenSuse with EFI.

Thank you.

In this case result if https://github.com/arvidjaar/bootinfoscript may be useful. Upload to http://susepaste.org/

My bios had both legacy and EFI enabled. Fedora used EFI and OpenSuse used legacy.

Well, if for some reasons your BIOS prefers EFI boot over legacy, this sounds like the very reason. You need to check BIOS options to chose legacy disk boot.