Leap 15 = Black Screen after boot

I just installed Leap 15 and KDE
After login a black screen appears
What can I do to get in?

What graphics card??

try nomodeset

At boot press e find line starting linux or linuxefi go to end of the line (it wraps) add space and nomodeset press F10 to continue boot

Thanks for the answer.
When I press the key between Ctrl and Alt the screen returns to normal
With this information maybe there is another way to solve this problem

Please check whether this issue is the same for a newly created user.

I rebooted the machine and now the screen remains black even if I press the key I mentioned earlier.
I tried to use the nomodeset but there is no line that you mentioned. I do not think the words “starting linux or linuxefi”
Please…What else should I do?

In the bootloader menu, hit ‘e’, then look for “showopts”, add a space behind it and ‘nomodeset’. If that works out OK, make it persistent by YaST - System - Bootloader - Kernelparameters, where you’ll see the same ‘showopts’ option, add it there, and reboot

Yes there is, but you’ll need to use the down arrow key to find it. Read the following if it’s still not clear to you…


OK thank you. Using “nomodeset” the desktop has returned.
But how do I get saved at boot?

su -
nano /etc/default/grub
Here add nomodeset
grub2-mkconfig -o /boot/grub2/grub.cfg

I made the indicated change and restart OpenSUSE and this time worked well.
I would like to know what caused this installation to fail.
So, I can avoid this problem in the future.
So? How did this happen?

nomodeset uses fall back drivers there is some problem with your video card driver selections.

Actually, after using your suggestion, the screen is different, but not worse.
I understand that “nomodeset” is a precarious solution … (or not?)…:)If so, what should I do to make it work right?

That really depends on your graphics hardware. No promises - it’s your machine. Share the details for others to advise further…

/usr/sbin/hwinfo —gfxcard

That’s the result:

audio:/home/sergio # /usr/sbin/hwinfo —gfxcard
oops: don't know what to do with "—gfxcard"
audio:/home/sergio # /usr/sbin/hwinfo --gfxcard
15: PCI 105.0: 0300 VGA compatible controller (VGA)             
  [Created at pci.378]
  Unique ID: ul7N.vM6Gs1xCX65
  Parent ID: vSkL.UaRN6fG_lZA
  SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:05.0
  SysFS BusID: 0000:01:05.0
  Hardware Class: graphics card
  Model: "ATI Radeon XPRESS 200 5A61 (PCIE)"
  Vendor: pci 0x1002 "ATI Technologies Inc"
  Device: pci 0x5a61 "Radeon XPRESS 200 5A61 (PCIE)"
  SubVendor: pci 0x103c "Hewlett-Packard Company"
  SubDevice: pci 0x2a4f 
  Memory Range: 0xc0000000-0xcfffffff (ro,non-prefetchable)
  I/O Ports: 0xa800-0xa8ff (rw)
  Memory Range: 0xff4f0000-0xff4fffff (rw,non-prefetchable)
  Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
  IRQ: 10 (no events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v00001002d00005A61sv0000103Csd00002A4Fbc03sc00i00"
  Driver Info #0:
    XFree86 v4 Server Module: radeon
  Driver Info #1:
    XFree86 v4 Server Module: fglrx
    3D Support: yes
    Extensions: dri
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #20 (PCI bridge)

Primary display adapter: #15

I have a Dell 320 Optiplex exactly the same as this that has no need for nomodeset and works just fine with TDE on 15.0. I do not have plymouth installed on my Dell. Is xf86-video-ati installed? You do need it. Try replacing nomodeset with plymouth.enable=0. If it produces a satisfactory result, remove plymouth.enable=0 and do

zypper rm plymouth

or equivalent package removal with yast2. If this does not work, share Xorg.0.log with us here.

Ok - nomodeset and + plymouth=0 then openSUSE work well.
But it is safe to remove the plymouth?

Yes it is just a splash screen nothing but eye candy. It hides the normal Linux startup logging.

… in addition to mrmazda and gogalthorp’s answers, as additional reassurance:
I love watching the scrolling lines at boot, I can see the work that the boot process is doing, which reassures me that something is happening, and I think it shows the actual power of the OS.

With a fancy splash screen, you can never be sure what – if anything – is actually happening while you are waiting for the login screen.

So, in all my machines, all installs, I remove and taboo Plymouth right away when doing the installs.

Yes, that’s a nice practice. Very good to know this
Many thanks to everyone.

This lack of knowing anything is actually happening is one reason why I never migrated from DOS to Windows last century. In OS/2 (as in Linux), there was an option to dispense with the secrecy during the interminable wait. lol!

So, in all my machines, all installs, I remove and taboo Plymouth right away when doing the installs.
TBC for the OP, one “removes & taboos” during installation by selecting “Details” after system role selection, and changing the checkbox for plymouth from either checked or empty to taboo/do not install.