Leap 15 black screen after boot selection

After multiple fresh install of Leap 15(media test OK), KDE Plasma with no error, still can not boot.
The screen turns black after the boot menu.

I have tried run level 5, 3 and one, with splash=verbose and quiet removed, still no go.

Only way to login is with nomodeset or radeon.modeset=0

This must be related to my video card, but it was running fine on Leap 42.2.

Any help would be appreciated, thanks

HP Pavilion Elite HPE-400f
AMD Phenom II X4 945
AMD Radeon HD 6670

So, it does boot, but KDE doesn’t work without either one of the options? Then use YaST’s bootloader module to add one permanently. It will rewrite the bootloader config and recreate an initrd.

Hi Knurpht,
Yes it does boot with nomodeset, but the resolution is only 1024x768 instead of 1920x1080 when it’s normal, the definition is, well, ugly.
Not to mention dmesg error(with nomodeset):
drm:radeon_init error no UMS support in radeon module!

However I got it to boot normally a few time only by removing “splash=verbose and quiet”, but not all the time, it’s intermittent.

When It goes black the monitor goes to sleep and the hard-drive activity indicator led turns off, like if everything is dead!


the same happened to me. After upgrading from leap 42.3 to 15, all worked fine for a few days, but this morning a black screen after boot selection (at the first start up of the day). The main difference from what stated above is that I was not able to change any console, no hard disk activity: just the black screen.
The only thing I could do was to pick up again my upgrade dvd and execute again an “upgrade”.
After that, the system went on in the right way, apart the problem I still got in the past of the internet access (no access to the internet but access to the local net) solved using the instruction “sudo netconfig update -f”.
All seems working fine (I keep my fingers crossed) now, it is starting a giant update (I think due to texlive files) and I will see.
However I do not understand what happened and why the system freezed that way.
My machine is a Hp laptop with A10 processor and Radeon R5.

Hi gio_kheper,

I don’t know about Radeon R5, but in my case (Radeon HD 6670) the installation detect the wrong video driver.
It uses amdgpu instead of radeon drivers, as a result it creates 10-amdgpu.conf in xorg.conf.d.

amdgpu is for recent card, not mine. But like you, when the screen turn black the hard drive stop.

I have Leap 42.2 who works perfectly with that adaptor and there is no 10-amdgpu.conf in xorg.conf.d.

lspci -v | grep driver on 42.2 give back: radeon

Sometime it will boot normally and in that case it uses radeon.

That’s what I know so far, still not fix


Hi noital,
thank you. After two reboots I got the same situation. What I did in the while was :
(1) installing lazarus for tumbleweed (not a very liked choice, but I need Lazarus 1.8.4 and not 1.8.2) and everything went right, i.e.no problem with reboots and so on
(2) adding, but not used, the packman repository
(3) installing codecs for kde through the site opensuse-community.org/codecs-kde.ymp

At reboot I got the black screen, this time with some work on the hard disk for a long time, without doing anything visible.

At this time I, again, made the “upgrade” from dvd, without touching anything, i.e. making nothing of the above, just leaving things as they are.

At the moment the machine booted, command lspci -v tell me that the used drive is amdgpu.

So I am going to see if there are errors while detecting drivers at start up. By the way I had no problems with 42.2/42.3. Tumbleweed gave me some problems (freezes while working etc.) so I stopped using it and moved to leap “stable”.

Now I am going to see what is happening next time.

Apparently the problem is that it can not determine the proper resolution and frequency of the monitor.
It’s not the module loading.

The directory:
contains 10-radeon.conf

I have copied 50-device.conf, 50-screen.conf and 50-monitor.conf from:
in 10-radeon.conf directory

Uncomment and edit them so it look like this:

Section "Device"
  Identifier "Default Device"
  Driver "radeon"
  Option "monitor-HDMI-0" "Default Monitor"


Section "Monitor"
  Identifier "Default Monitor"
  HorizSync 28-85
  VertRefresh 50-100
  Modeline "1920x1080_59.94"  172.75  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync


Section "Screen"
  Identifier "Default Screen"
  Device "Default Device"
  DefaultDepth 24
  SubSection "Display"
   Depth 24
   Modes "1920x1080"

Now it still goes black for 4 or 5 seconds, but it lights back up and works perfectly every time.

Hi noital,
just copied all the files while still leaving in the directory all the file marked 10*.
The new data should not be the corrected one for my monitor, because it started flickering and my only way to proceed was to go on a consolle, while still flickering, and to delete the three 50* files just added (by the way while in consolle, no X11, it stopped flickering after deleting 50-device.conf).
Now I will going to study my monitor.

Substituting the following 50-monitor.conf for that in #7 should work better for Xorg, have no effect on framebuffer:

Section "Monitor"
  Identifier "Default Monitor"
  HorizSync 28-85
  VertRefresh 59-61
  Option "PreferredMode" "1920x1080"

Something else to try is removing the xf86-video-ati and xf86-video-amdgpu packages, which should result in use of the modesetting driver that is integral to the server. With my two HD 5000s and HD 6450 it is what I do.

If neither do enough, you may need to change the Option “monitor-HDMI-0” “Default Monitor” line in 50-device.conf to match the “connected” line in Xorg.0.log, which may be HDMI-1 or something else, since it is driver, gfxchip and connector type dependent. It may not need any such line. It may neither need any Driver line, especially if trying to use the modesetting driver.

Hi and thank you all,
My laptop seems to have a 1366x768 resolution, so I tried always with these values.
Just changing settings as the previous suggestions, did not lead to stop flickering.
For now, always keeping my finger crossed, I gave up to the radeon drive and use the amdgpu one as 10-amdgpu.conf.
By the way this is the one I see it has been used by MX-Linux, for instance. Maybe not all the supposed power of radeon, but hoping it still holds up my system.

Hi mrmazda,
I have edited 50-monitor.conf as you suggested and remove xf86-video-amdgpu package.


Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
HDMI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 479mm x 269mm
   1920x1080     60.00*+  59.94  
   1600x1200     60.00  
   1680x1050     59.88  
   2880x480      60.00    59.94  
   1280x1024     60.02  
   1440x900      59.90  
   1280x960      60.00  
   1280x720      60.00    59.94  
   1024x768      60.00  
   800x600       60.32  
   720x480       60.00    59.94  
   640x480       60.00    59.94  
DVI-0 disconnected (normal left inverted right x axis y axis)
VGA-0 disconnected (normal left inverted right x axis y axis)

It works fine, but boot is the same; it goes black for 5 seconds.
But I don’t really care, because it’s working every time, oppose to 1 in 5 at the beginning…


Black for the several seconds before kernel modesetting kicks in seems to be somewhat common. I’ve been thinking GFX BIOS creators and display manufacturers have stopped testing to ensure full VESA compliance before release, being content to have bloated GUI BIOS modes working, and working handoff to Windows 10 and OS X splash screens.