Leap 15 Beta - Please post any initial comments here

I have an older nvidia card (gt710) and I don’t do games. I had no trouble with nvida proprietory driver but the ‘hard way’ was becoming a bit of a hassle every time the kernel updated so I tried nouveau again and it works fine- on 42.3, tumbleweed and 15 beta so I’ve stuck with it
Originally I used to get frequent freezes calling for a complete reboot with nouveau. Not any more.

Did you install Mesa-dri-nouveau?
Without it, OpenGL will use Mesa’s software renderer, which is indeed slow of course.

nouveau likely won’t reach nvidia’s performance level, but I think it shouldn’t be 10 times slower either…

~]: rpm -q Mesa-dri-nouveau 

On some tests it is less than 10 times but still significantly slower.


Using zypper this time rather than yast I went ahead with option 2 (break) and the install - with many, many files of the lib32 variety - proceeded.

Building reports flashed by until eventually I witnessed initrd being created.

I have rebooted and can report that I am using legacy nvidia 340.104


Could someone of try the following:

  1. Login Wayland session
  2. Unplug monitor cable and plug in again
    Does the screen reappear?

In my case it stays black but the PC keeps running.


Installed Smplayer and gstreamer-plugins-ugly.
Played mp3 files OK but no video for example mp4 or mkv.

Installed vlc to see if there were additional codecs that might make a difference.
Again only mp3 files played - crashed with mp4 and mkv video files.

Added packman for tumbleweed repo, switched system packages to packman

This action resulted in both audio and video files playing in Smplayer.

I haven’t re-installed vlc from pacman yet so can’t comment.


Sure, openSUSE cannot ship mp4 support for legal reasons.

The mp3 patents have expired last year, so this works now (also in 42.2 and 42.3).

Leap 15 has a packman repo of its own which I think include all the necessary codecs. Certainly, I’ve had vlc working since alpha days (including mp4 videos).


Of course I should have made a ref to(about VB):


Tested on VB 5.1.32/5.2.26. Mea culpa. Tested whit(even manual) guest-additions but no.

Today (20180209), -a zypper dup and its working on VB(5.1.32).

Also a zypper dup on raw iron and Digikam 5.80 show up and working with ext SQL-server. Also tested HPLIP trow jetdirekt and it seems working.

About Se (Swedish) translation its getting better by every release :wink:


Cannot find it, please share the URL

Here you go…

Packman mirrors can be found here…

Leap15? Wayland…

I did ask a question a couple of years ago. Now I reading:

According to:


Yup I tested with ver leap15 and all its gave was a black screen and back to the standard loginscreen (plasma), -its not standard yet.

Will I be able to call for remote machines like in the future, like:

ssh -X username@computer ? If not its something similar in Wayland?



I’ve installed Leap 15 beta on a Fujitsu S761. Everything works fine but I have a problem with my Bluetooth box/headset I reckon it’s a problem with PulseAudio 11.1:

The box is connected and paired:

[cha cha 2]# info
Device E1:82:56:DC:3E:51 (public)
    Name: cha cha 2
    Alias: cha cha 2
    Class: 0x00240404
    Icon: audio-card
    Paired: yes
    Trusted: yes
    Blocked: no
    Connected: yes
    LegacyPairing: no
    UUID: Audio Sink                (0000110b-0000-1000-8000-00805f9b34fb)
    UUID: A/V Remote Control        (0000110e-0000-1000-8000-00805f9b34fb)
    UUID: Handsfree                 (0000111e-0000-1000-8000-00805f9b34fb)
    RSSI: -44

But PA cannot show the box/headset as sound device. It only shows the internal speakers of my laptop, so I cannot play sound on the box:

$ pacmd list-cards 
1 card(s) available.
    index: 0
    name: <alsa_card.pci-0000_00_1b.0>
    driver: <module-alsa-card.c>
    owner module: 6
        alsa.card = "0"
        alsa.card_name = "HDA Intel PCH"
        alsa.long_card_name = "HDA Intel PCH at 0xe2720000 irq 36"
        alsa.driver_name = "snd_hda_intel"
        device.bus_path = "pci-0000:00:1b.0"
        sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
        device.bus = "pci"
        device.vendor.id = "8086"
        device.vendor.name = "Intel Corporation"
        device.product.id = "1c20"
        device.product.name = "6 Series/C200 Series Chipset Family High Definition Audio Controller"
        device.form_factor = "internal"
        device.string = "0"
        device.description = "Internes Audio"
        module-udev-detect.discovered = "1"
        device.icon_name = "audio-card-pci"
        input:analog-stereo: Analog Stereo-Eingabe (priority 60, available: unknown)
        output:analog-stereo: Analog Stereo-Ausgabe (priority 6000, available: unknown)
        output:analog-stereo+input:analog-stereo: Analog Stereo Duplex (priority 6060, available: unknown)
        output:analog-surround-40: Analog Surround 4.0-Ausgabe (priority 700, available: unknown)
        output:analog-surround-40+input:analog-stereo: Analog Surround 4.0-Ausgabe + Analog Stereo-Eingabe (priority 760, available: unknown)
        output:hdmi-stereo: Digital Stereo (HDMI)-Ausgabe (priority 5400, available: no)
        output:hdmi-stereo+input:analog-stereo: Digital Stereo (HDMI)-Ausgabe + Analog Stereo-Eingabe (priority 5460, available: unknown)
        output:hdmi-surround: Digital Surround 5.1 (HDMI)-Ausgabe (priority 300, available: no)
        output:hdmi-surround+input:analog-stereo: Digital Surround 5.1 (HDMI)-Ausgabe + Analog Stereo-Eingabe (priority 360, available: unknown)
        output:hdmi-surround71: Digital Surround 7.1 (HDMI)-Ausgabe (priority 300, available: no)
        output:hdmi-surround71+input:analog-stereo: Digital Surround 7.1 (HDMI)-Ausgabe + Analog Stereo-Eingabe (priority 360, available: unknown)
        off: Aus (priority 0, available: unknown)
    active profile: <output:analog-stereo+input:analog-stereo>
        alsa_output.pci-0000_00_1b.0.analog-stereo/#0: Internes Audio Analog Stereo
        alsa_output.pci-0000_00_1b.0.analog-stereo.monitor/#0: Monitor of Internes Audio Analog Stereo
        alsa_input.pci-0000_00_1b.0.analog-stereo/#1: Internes Audio Analog Stereo
        analog-input-internal-mic: Internes Mikrofon (priority 8900, latency offset 0 usec, available: unknown)
                device.icon_name = "audio-input-microphone"
        analog-input-mic: Mikrofon (priority 8700, latency offset 0 usec, available: no)
                device.icon_name = "audio-input-microphone"
        analog-output-speaker: Lautsprecher (priority 10000, latency offset 0 usec, available: unknown)
                device.icon_name = "audio-speakers"
        analog-output-headphones: Kopfhörer (priority 9000, latency offset 0 usec, available: no)
                device.icon_name = "audio-headphones"
        hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: no)
                device.icon_name = "video-display"

I tried the fix from bugzilla and added this line

load-module module-bluetooth-discover autodetect_mtu=false

to */etc/pulse/default.pa *but without success.


After the last update (some 2000 packages incl. kernel updates) grub doesn’t see my TW (with its own /boot partition) and my WIndows installation. After os-prober and updating grub at least it finds Windows now, however TW still remains gone.
What to do?

I’m not sure that is supported yet.
Wayland is still a bit work-in-progress…

And some things will never be supported anyway because of the possible security issues.

File a bug report at bugzilla.opensuse.org (same username/password as here), if there isn’t one already.

Will do.

Had to boot into Leap afterwards, mount the encrypted LVM of TW and then run os-prober. After that TW showed up in Grub again.

Oh boy, after the recent update to 127.1 it happened again. :frowning:

Now that Beta test build 127.1 has been published, I’ve started a new thread: <https://forums.opensuse.org/showthread.php/529677-Leap-15-Beta-Build-127-1-Please-post-any-initial-comments-here>.