LEAP-15.6 : Tigerlake speaker sound impacted by MS-Windows mute setting

I was surprised to stumble across this - where I believe a muting of the speaker sound in MS-Windows carried through to GNU/Linxu - and I am still not 100% certain I believe this.

For a while I could not get ‘speaker sound’ to properly work on my Lenovo X1 Gen9 laptop with a fresh LEAP-15.6 install (earlier today). Headset sound worked fine. I tried different sof-firmware versions that made no difference. I checked all the standard places (alsamixer, pavucontrol, amixer, ran alsa-info.sh to check configuration) where in particular pavucontrol indicated sound should be coming out of the speakers - but there was next to no sound (there was thou a very quiet scratching sound in the speakers (where if all volume controls turned up 100% (some even to 150%) . I speculated this ‘scratching’ could be the sound muted massively.

Note that if I plugged in a headphone would I get very good sound.

I tried all the standard sound tests to confirm this (aplay, speaker-test, yast, various apps).

I noted sound worked ok under LEAP-15.3 the previous day.

I booted to a LEAP-15.6 KDE live USB just to confirm this was not a bad install (in my LEAP-15.6) and sound did not work there either - which was funny - as a couple days earlier I had sound working with this LEAP-15.6 KDE live USB. So I started(1) questioning my memory about that previous live USB test, and (2) being suspicious of a LEAP-15.6 kernel or sof-firmware bug (?) .

I decided to test sound under MS-Windows (I have a dual boot there I never hardly ever use). When I went to Windows, and tried to play sound (youtube video) and there was no sound until I noted in Windows that the volume was muted. I unmuted the volume in MS-Windows and immediately sound worked fine in the speakers in MS-Windows!

Suspicious there could be more to this I then booted to LEAP-15.6, and sound worked fine immediately now in LEAP-15.6 with the speakers in this Lenovo laptop. Go figure.

I speculate MS-Windows can mute/unmute the sound at a different level (?) relative to the hardware then LEAP? But that is speculation. If such is the case, GNU/Linux should be able to do the same - and that still makes me think GNU/Linux could have a bug here.

This was most bizzare. I don’t ever recall encountering such before.

In case any are curious … here is the " inxi -Aa " output.

Audio:
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Lenovo
    driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:a0c8 class-ID: 0403
  API: ALSA v: k6.4.0-150600.21-default status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: PipeWire v: 1.0.5 status: off with: 1: wireplumber
    status: active 2: pw-jack type: plugin tools: pw-cat,pw-cli,wpctl
  Server-2: PulseAudio v: 17.0 status: active with: pulseaudio-alsa
    type: plugin tools: pacat,pactl,pavucontrol

That was an interesting investigation.

I am now back to fine tuning my LEAP-15.6, adding the apps that I like to have installed.

I was chatting with a friend, and he pointed out to what could have been the issue with LEAP-15.6 when I encountered the problem with no sound to the speakers on my Lenovo laptop.

This Lenovo X1 carbon gen-9, like most laptops, has a row of function keys on the top, which I never use (except when I want to boot to BIOS, or when I want to boot to the Lenovo’s boot menu (which is different from grub)).

I recall after successfully testing LEAP-15.6 live KDE USB (where sound worked), that a couple of days later I made the install of LEAP-15.6 on this Lenovo. I first wanted to boot to the BIOS, and I could not recollect what function key to press to boot to BIOS.

It is quite possible I multiple rapidily pressed different function keys, including the key that mutes the speaker sound. The fact that such a key would function early in the boot process surprises me, and that may be something I check later if such is the case.

But the friend’s theory is I muted the speaker sound with the function key, and hence I could not hear it with LEAP-15.6. And while the GNU/Linux kernel sound driver does not provide the ability to over ride that function key, the friend’s theory is that the MS-Windows sound driver does provide the capability to override that keyboard function key.

I am not yet convinced this was the case - but it is a theory that I can check.