Leap 15.5 to 15.6 . . . zypper dup finds "two problems"?

I used YaSt to edit the enabled repos from “15.5” to “15.6” and after updating grub list, rebooting shows “15.6 Alpha” where once was 15.5 . . . log in went well. To check to see if zypper would now pull in any packages I ran a zypper dup -l and it found "two questions that require your apt attention . . . "

Some of the items in the repos that were not enabled wouldn’t show the “15.5” line item, so they couldn’t be edited?? Also now remembering that I probably should have deleted Packman repos, but I just left that as it was “release server”?? Would deleting Packman make any difference to the questions?

Or, I have to answer these questions anyway . . . traditionally I would just click on something, but I have learned that doesn’t always work out too well. Any hints on which answer is the correct answer??

All repositories have been refreshed.
Loading repository data...
Reading installed packages...
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
Computing distribution upgrade...
2 Problems:
Problem: problem with the installed libopencore-amrnb0-0.1.6-150500.1.pm.2.x86_64
Problem: problem with the installed libopencore-amrwb0-0.1.6-150500.1.pm.2.x86_64

Problem: problem with the installed libopencore-amrnb0-0.1.6-150500.1.pm.2.x86_64
 Solution 1: install libopencore-amrnb0-0.1.6-bp156.1.1.x86_64 from vendor openSUSE
  replacing libopencore-amrnb0-0.1.6-150500.1.pm.2.x86_64 from vendor http://packman.links2linux.de
 Solution 2: keep obsolete libopencore-amrnb0-0.1.6-150500.1.pm.2.x86_64

Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c/d/?] (c): 

Yes, if the Packman repos are deleted (and they should be, as they don’t exist for 15.6 Alpha - Packman typically becomes available for a release around release time), then what’s happening is it’s looking to replace the Packman-owned packages with packages from the OSS repo.

Mixing packages from different releases is strongly discouraged, as it can lead to all kinds of problems, so you’re going to lose proprietary codecs while you run 15.6 Alpha code.

1 Like

Packman Repo for Leap 15.6 is there:

But libopencore-amrnb0 is not build for Leap 15.6 in Packman.

OK, well glad to hear that Packman might be there . . . . I was working in another OS and when I rebooted to try to get back to 15.6 the second time it wouldn’t load the GUI log in . . . and went to “emergency mode”?? I logged into that and looked at the suggested “journalctl -xb” and it showed some stuff about “your BIOS has some problems with the code???”

So, “oopsie” . . . I don’t know what the command is to “nano” the sources.list in Leap . . . over in my old Lubuntu install when I want to upgrade I run “sudo nano /etc/apt/sources.list” and then make the edits there . . . .

The question is now do I need to still remove Packman repos to be able to run a clean zypper?? Or since I didn’t answer the questions the gatekeeper has increased the level of difficulty on the questions such that it will only load the emergency TTY???

I’m asking thiese questions back over in master-blaster TW GUI system . . . Leap 15.6 seems to have come up “lame”???

You can use

Yast should also work from Runlevel 3 with an ncurses Interface.

Also you can edit the Repos stored in /etc/zypp/repos.d/

OK, thanks for those hints. I guess my question still is, “What happened to the GUI?” because I rebooted the first time into it and got to the GUI terminal and ran the zypper and it asked me the special questions . . . ???

What am I going to do if I run “yast” in the TTY?? Should I run another “zypper dup -l” and try to get the questions to show up again?? And if they show up, what are “my answers” going to be?

Do I need to try to delete Packman and then try to add it back?? These kind of questions.

[edit: rebooted the third time and GUI for Leap is back in play? Now where do I go from here?]

I do not know, what is going on on your System.

Its an alpha you have installed.

And your Main-Problem with the 2 Problems in zypper should be solved with Solution 1.

1 Like

OK, thanks for offering that as the preferred answer, essentially changing vendors to OpenSUSE??

I checked YaSt out and it does now show Packman as “15.6” . . . but then after that was still showing the questions.

I’ll run zypper again and make that change and hopefully that will boost it on through and into exploration of 15.6.

[edit: Part of the “oddness” is that in between upgrading the Leap system to 15.6 I booted a live iso of ubuntu mantic . . . and now in Leap console it shows the ’
/home user of “xxxxx@ubuntu” . . . so seemingly “ubuntu” has insinuated itself into the BIOS??? Running the zypper commands did run through without a problem and rebooting back into 15.6 was “OK,” but console is still showing “@ubuntu”??? One of the reasons I drifted away from ubuntu, because it does seem to want to be in charge of everybody??]

The default for Leap, is to get the hostname via DHCP. It could be that your router learned “ubuntu” as hostname when running that live Ubuntu system. And now it is returning to DHCP queries.

If that’s the issue, then you can just set your hostname manually.

1 Like

Seems like this system wasn’t updated for a really long time. libopencore-amrnb0 and libopencore-amrwb0 where removed from packman a looooong time ago so you need to switch them to openSUSE repos (solution 1).


Thanks for the follow up . . . so, as long as the Leap system is able to update itself . . . not too much of a concern. I just was trying to figure out, why after updating to 15.6, it logged into GUI OK, then it didn’t and then it did . . . ??? Seems like it’s more or less under control now.


??? Leap 15.5 was updated weekly for as long as I was using it . . . many months. Now, with 15.6 it’s been upgraded twice in one day . . . via zypper dup -l . . . .

Huh. That’s news to me - I don’t think they’ve ever had a repo for a pre-release alpha before. Good to hear!

I installed 15.6 on Aug. 19th. I have not seen any updates.

Maybe you are just seeing it pull in some recommends. For me, that would have happened when I installed additional software shortly after the original install.

It was anounced on the Packman Mailing list:

Send Packman mailing list submissions to


To subscribe or unsubscribe via the World Wide Web, visit

Packman Info Page

or, via email, send a message with subject or body ‘help’ to


You can reach the person managing the list at


When replying, please edit your Subject line so it is more specific

than “Re: Contents of Packman digest…”

Today’s Topics:

  1. Heads up openSUSE Leap 15.6 setup is being finalized

(Lubos Kocman)

  1. Re: Heads up openSUSE Leap 15.6 setup is being finalized

(Olaf Hering)

Message: 1

Date: Mon, 14 Aug 2023 13:24:07 +0000

From: Lubos Kocman <lubos.kocman@suse.com>

To: “packman@links2linux.de” <packman@links2linux.de>

Subject: [packman] Heads up openSUSE Leap 15.6 setup is being


Message-ID: <d9fee6f9c247e530480388e93fee5d0f1fd7768a.camel@suse.com>

Content-Type: text/plain; charset=“utf-8”

Hello packman team!

we did receive a openSUSE Leap 15.6 request for a faster adaptation of

Packman repos Issue #118: Request for faster adaptation of Packman repos for 15.6 - features - Pagure for openSUSE

Regarding the current state of 15.6

We’re already have a first 15.6 build in openQA (got there 36 minutes

ago ![:-)|22x22](file:///usr/share/emoticons/Breeze/face-smile.png “:-)”)


The Beta is scheduled for second half of February.

openSUSE:Roadmap - openSUSE Wiki

Let me know if there is any way how I could assist to meet our user


Thank you!

Best regards

Lubos Kocman

openSUSE Leap Release Manager

Message: 2

Date: Tue, 15 Aug 2023 23:04:06 +0200

From: Olaf Hering <olaf@aepfle.de>

To: Lubos Kocman <lubos.kocman@suse.com>

Cc: “packman@links2linux.de” <packman@links2linux.de>

Subject: Re: [packman] Heads up openSUSE Leap 15.6 setup is being


Message-ID: <20230815230406.173d4f49.olaf@aepfle.de>

Content-Type: text/plain; charset=“utf-8”

Mon, 14 Aug 2023 13:24:07 +0000 Lubos Kocman <lubos.kocman@suse.com>:

we did receive a openSUSE Leap 15.6 request for a faster adaptation of
Packman repos Issue #118: Request for faster adaptation of Packman repos for 15.6 - features - Pagure for openSUSE

It is ready for download since a few weeks:

Index of /packman/suse


-------------- next part --------------

A non-text attachment was scrubbed…

Name: not available

Type: application/pgp-signature

Size: 833 bytes

Desc: Digitale Signatur von OpenPGP

URL: http://lists.links2linux.de/pipermail/packman/attachments/20230815/aa38059a/attachment-0001.sig

Subject: Digest Footer

Packman mailing list


Packman Info Page

1 Like

Looks like my email reply to your post didn’t make it into the thread???

The first update was the move from 15.5 to 15.6 . . . then after getting back into the GUI there was a number of packages that seemed to be labeled “packman” that went through yesterday as well . . . so, in that sense “one upgrade” since the move to 15.6 . . . .

openSUSE has no equivalent to sources.list. Sources.list configures each repo on one line within one file. The Debian Apt system used by *buntu also allows sources to be configured via /etc/apt/sources.list.d/, which is similar to the openSUSE method of one file per source in /etc/zypp/repos.d/, with several lines per file for configuration details, similar to Yum repos in Fedora and CentOS.

Files in /etc/zypp/repos.d/ can be edited by any plain text editor, or any other editor capable of saving files as pure plain text. Those unfamiliar with content of these .repo files should stick to using YaST and/or zypper for managing them.

1 Like

At that time I thought I had lost my GUI system and could only edit via TTY . . . to make some potential change to the repos.

Turned out that Packman was OK and the GUI came back online . . . didn’t have to mess with the repos other than what I did in YaSt to change the “15.5” to “15.6” and all seems “OK.”

Cool, thanks for sharing that :slight_smile: