Leap 15.5 clean installation with DVD ISO, getting "Wrong digest" at start of installer

Downloaded today the DVD ISO, checked the checksums.

Burned to USB with dd, again checked checksums.

Booted from created USB, when installation is about to begin, even before loading the EULA, I get this:

Wrong digest

The expected checksum of file /var/tmp/AP_0xeavkbA/x86_64/<some_package>
is 8520cf585b2a5873c3dd8e9a89a0b1953acc175d0b5e2b72b00e860cba86b60a,
but the current checksum is 7bdfc38d0501a10743751c6158503ad22f5f0bafbe85bab4667b6c308d3d4aeb.

The file has been changed by accident or by an attacker
since the repository creator signed it. Using it is a big risk
for the integrity and security of your system.

Use it anyway?

From here cannot proceed with installation at all.

Why is this?

Try again. This time, when it asks whether to use online repos, say “no”. That way you will know that this is a problem with the install iso rather than with a package downloaded from the online repos.

If this still happens, you might have a defective USB drive.

Just to be sure. How did you copy (not “burn”, that will destroy the device into a smoking heap) it. Yes, you used dd. That is fine, but you know we like to see full statements posted here. I understand you can not copy/paste what you did hours (days) ago, but you still can show us the command from memory. This because some people use the wrong target for the copy.

If you have Windows installed you have to verify you disk partitions and also verify if your disk is encrypted.

I used
dd if=path/to/openSUSE.iso of=/dev/sdb bs=1M status=progress; sync

No Windows installed.

Tried again, this time with no network connection at all since beginning, exact same error; faulty drive…

Thanks. Looks perfect to me.

Yes, I’m suspecting a faulty USB drive. Try another one.

I have done several installs that way, and without any problems.