Leap 15.5 black windows

I’d been using Leap 15.4 fine for a year but after upgrading to Leap 15.5, windows sometimes display black boxes instead of their content.
Here’s what led to this:
I upgraded from 15.4 to 15.5. After that, I had to reinstall Nvidia drivers because system GUI didn’t load. After reinstallation, it started working again. Currently I have -G05 drivers from Nvidia repository (tried installing -G06, no difference)
Black windows don’t apper immediately after booting up. They appear only after some time(a day, or two).
Those black boxes are also apply to context menus. alt-tab menu, etc…
My system:
Operating System: openSUSE Leap 15.5
KDE Plasma Version: 5.27.4
KDE Frameworks Version: 5.103.0
Qt Version: 5.15.8
Kernel Version: 5.14.21-150500.53-default (64-bit)
Graphics Platform: X11
Memory: 15,6 GiB of RAM
Graphics Processor: NVIDIA GeForce GTX 1070/PCIe/SSE2

How can I fix that?

Does it work when you drag the window towards the top screen a little faster?

Have you tried to use the nouveau?

I have had also Problems with Nvidia driver after a while when opening a submenu by rightclicking such as “save as” in dolphin/krusader or in firefdx “open in new tab” or something else.

Its gone since I use nouveau.
My card:

inxi -G
Graphics:
  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] driver: nouveau v: kernel
  Device-2: WaveRider USB Live camera type: USB
    driver: snd-usb-audio,uvcvideo
  Display: x11 server: X.Org v: 1.21.1.4 with: Xwayland v: 22.1.5 driver: X:
    loaded: modesetting unloaded: fbdev,vesa dri: nouveau gpu: nouveau
    resolution: 1: 1920x1080~60Hz 2: 1920x1080~60Hz
  API: OpenGL v: 4.3 Mesa 22.3.5 renderer: NV136

The only action that might (sometimes) restore displaying of a window content is window minimising/maximising. Any other action with a window don’t produce any effect.

I remember using Nouveau some time ago before that problem and I think its performance was too low for gaming as I play games sometimes. I’d prefer using Nvidia drivers for performance.

So you have to open an bugreport.

@tormashka:

It looks as if, somehow, no idea how but, you seem to have selected a “Darkscheme, somehow …

  • BTW: from the image you’ve posted it seems that, you’re using the KDE Plasma Desktop.

  • Please, check the following in your KDE Plasma System Settings –
    Appearance” → “Global Theme” –– possibly, it’s set to “Breeze Dark
    Possibly – “Appearance” → “Plasma Style” is, possibly, set to “Oxygen” …
    Possibly – “Appearance” → “Colors” is, possibly, set to either “openSUSEdark” or “openSUSEdarkalternate” or, something else which is “Dark” …

Ditto for Firefox – “Addons and Themes” → the selected Theme …

There aren’t any issues for several hours after booting into system, so it’s not related to any theme/style preferences I have set.
Black boxes appear in light theme as well.

Hmmm –

This Leap 15.5 system:

Operating System: openSUSE Leap 15.5
KDE Plasma Version: 5.27.4
KDE Frameworks Version: 5.103.0
Qt Version: 5.15.8
Kernel Version: 5.14.21-150500.55.12-default (64-bit)
Graphics Platform: X11
Processors: 8 × AMD Ryzen 5 3400G with Radeon Vega Graphics
Memory: 29.3 GiB of RAM
Graphics Processor: AMD Radeon Vega 11 Graphics
Manufacturer: ASUS

Occasionally (less than once a week) what I was seeing, concerning only Mozilla Firefox and Web-Browsing, was either a blacked-out Firefox window or, not so often, a blacked-out Desktop.

  • The window or Desktop resumed to normal behaviour after a second or so of mouse movement.

I haven’t been plagued by this during this week (it’s now Friday) – possibly a patch has resolved the issue …

This was also the behavior on my system, but I went back to nouveau.

So as I said above:
open an bugreport.

Do you use a dark gtk Theme?

Can you switch to a brighter one?

Does that work?

I have “Breeze dark” as the global theme and also have “Breeze” selected under “Global theme” => “Application style” menu
Have already tried changing Breeze Dark to Breeze (light) but it didn’t change anything.

I think I need a little nudge before opening a bug report as I haven’t seen those black boxes for a couple of days, and I’m a bit lazy getting familiar with how bug reporting works, though they will certainly appear again, so it’s only a question of time.

I just noticed that after restarting Firefox, this bug seems to completely dissapear.
I don’t have any clue why.

1 Like